Article ID: 198532 - Last Review: March 14, 2005 - Revision: 2.2

FIX: ADO: Unable To Update Memo Field > 64K In Access Database

This article was previously published under Q198532
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SYMPTOMS

An attempt to update a large (64K or greater) memo field in a client-side recordset using the Jet 3.51 OLE DB provider results in one of the following errors:
Errors occurred.
Run-time error '-2147217887(80040e21)':
-or-

Run-time error '-2147217259(80040005)': Data provider or other service returned an E_FAIL status.

CAUSE

This problem is caused by a bug in the Microsoft OLE DB Provider for Jet version 3.51.

RESOLUTION

This problem only occurs when using the Microsoft OLE DB Provider for Jet version 3.51 and client-side recordsets.

This problem does not occur if you use the Microsoft Access ODBC driver or a server-side recordset.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article.

This bug has been fixed in the Microsoft OLE DB Provider for Jet versions 4.0 and later.


APPLIES TO
  • Microsoft OLE DB Provider for Jet 3.51
  • Microsoft ActiveX Data Objects 2.0
  • Microsoft ActiveX Data Objects 2.1
  • Microsoft ActiveX Data Objects 2.5
  • Microsoft Data Access Components 2.0
  • Microsoft Data Access Components 2.5
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
Keywords: 
kbado210sp2fix kbbug kbfix kbjet kbmdacnosweep KB198532
 

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