Article ID: 214842 - Last Review: July 11, 2005 - Revision: 2.2 PRB: Installed DeskBand Not Displayed in Taskbar Shortcut MenuThis article was previously published under Q214842 SYMPTOMS
After you install a desktop band object, the band object should be available to the user in the taskbar shortcut menu under Toolbars. On Windows 2000, the newly installed band object might not be present in the Toolbars menu. Restarting the computer does not correct this problem.
CAUSE
The Windows 2000 shell caches the available desktop band objects and only updates this cache if it senses that an installation application is run or if the cache location in the registry is not present.
RESOLUTION
The ideal solution is to install your desktop band object from an application that has the name Setup.exe or Install.exe. This prompts the shell to rebuild the desktop band object cache. If this solution is not feasible in your situation, you need to delete the following registry key: IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base: 256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
HKEY_CLASSES_ROOT\Component Categories\{00021492-0000-0000-C000-000000000046}\En
This causes the shell to rebuild the desktop band object cache the next time the user views the taskbar shortcut menu.
STATUS
This behavior is by design.
| Article Translations
|
Back to the top
