Article ID: 224431 - Last Review: October 7, 2005 - Revision: 3.2

Cannot Use RFC 1867 Over Proxy Server to Upload a Large File with NTLM Authentication

This article was previously published under Q224431
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SYMPTOMS

You may not be able to upload a large file using NTLM authentication through Microsoft Proxy Server to a Web server using Basic authentication.

CAUSE

For file downloads and ASP requests, Internet Explorer sends both a "Proxy-Authorization: NTLM xxx" and an "Authorization: Basic: xxx" HTTP header upon every "407 Proxy authentication required" response from Proxy Server. Problems arise if a large amount of data is posted.

The client first posts the data to Proxy Server, including an "Authorization: Basic: xxx" HTTP header as expected. Proxy Server replies with "407 Proxy authentication required," as expected. The client then posts the data again, but with an "Authorization: Basic: xxx" HTTP header, leaving out the needed "Proxy-Authorization" HTTP header.

Proxy Server then replies again with "407 Proxy authentication required" because the authentication request was not honored. At this point, Internet Explorer generates the error message "Internet Explorer cannot open the Internet site name. Not enough storage is available to process this command."

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

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DateTimeVersionFile namePlatform
09/30/9820:114.72.3509.3001Wininet.dll(x86)

STATUS

Microsoft has confirmed this to be a problem in Microsoft Internet Explorer version 4.01.

This problem has been fixed in Internet Explorer 4.01 SP2 and Internet Explorer 5.

APPLIES TO
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.0 128-Bit Edition
Keywords: 
kbenv kberrmsg kbprb KB224431
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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