Article ID: 231274 - Last Review: November 1, 2006 - Revision: 1.1

Macintosh Client Computer May Hang When Searching for Files

This article was previously published under Q231274
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SYMPTOMS

When you search for files on a Macintosh client computer, the computer may temporarily stop responding (hang). This behavior occurs even though the CatSearch function is disabled on the Macintosh volume the client is searching.

CAUSE

The Macintosh client may be running an AppleScript that requests a CatSearch, even though the CatSearch function is disabled.

When the CatSearch function is disabled on a Macintosh volume, the information is passed to Macintosh clients when volume parameters are passed, and the clients do not search volumes by requesting a CatSearch. Instead, they perform an Enumerate request. However, Macintosh clients can run an AppleScript that overrides the information passed to the client so the client can request a CatSearch.

RESOLUTION

To resolve this issue, alter or remove the AppleScript.

MORE INFORMATION

You can verify whether or not the Macintosh client is using the CatSearch function by performing a network trace during the slowness between the Macintosh client and the Windows NT Server-based computer hosting the Macintosh volume.

REFERENCES

For additional information, please see the following articles in the Microsoft Knowledge Base:
162189  (http://support.microsoft.com/kb/162189/EN-US/ ) Macintosh Clients May Hang Temporarily with Multiple Mac Volumes
158796  (http://support.microsoft.com/kb/158796/EN-US/ ) Macintosh Clients Connected to WinNT Server Appear to Hang

APPLIES TO
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 1
  • Microsoft Windows NT 4.0 Service Pack 2
  • Microsoft Windows NT 4.0 Service Pack 3
Keywords: 
kbnetwork kbprb KB231274
 

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