Article ID: 242934 - Last Review: January 25, 2007 - Revision: 3.4

Windows Stops Responding When Sending System Broadcast Message During Shutdown

This article was previously published under Q242934
Expand all | Collapse all

SYMPTOMS

When you click Shut down and then click OK in the Shut Down Windows dialog box, your computer may stop responding (hang) while the following message is displayed:
Windows is shutting down.
NOTE: This article and the update it describes is superceded by the following Microsoft Knowledge Base article:
260067  (http://support.microsoft.com/kb/260067/EN-US/ ) Windows Stops Responding During Shutdown with Mapped Drives

CAUSE

During shutdown, a WM_DEVICECHANGE message is broadcast to all top-level windows. This broadcast informs each window of a DBT_DEVICEREMOVECOMPLETE event. If a window does not respond to the broadcast system message, the computer may hang.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
Date        Time    Version    Size     File name   Platform
-------------------------------------------------------------------------
10/19/1999  07:40p  4.10.2223  549,600  User.exe    Windows 98 Second
                                                    Edition 
08/24/2000  05:05p  4.00.954    44,544  User32.dll  Windows 95 (all 
                                                    versions)
08/24/2000  04:54p  4.00.954   462,560  User.exe    Windows 95 (all 
                                                    versions)
				

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
238096  (http://support.microsoft.com/kb/238096/EN-US/ ) Problems Shutting Down Windows 98 Second Edition

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
206071  (http://support.microsoft.com/kb/206071/EN-US/ ) General Information About Windows 98 and Windows 98 Second Edition Hotfixes
For additional information about Windows 95 hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
161020  (http://support.microsoft.com/kb/161020/EN-US/ ) Implementing Windows 95 Updates

APPLIES TO
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 95
Keywords: 
kbhotfixserver kbqfe kbenv kbprb KB242934
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations