Article ID: 244334 - Last Review: October 2, 2002 - Revision: 1.0 OLEXP: "Error: -16999" Retrieving E-mail with Outlook Express 5 for MacintoshThis article was previously published under Q244334 For information about the differences between Microsoft Outlook Express and Microsoft Outlook e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base: 257824
(http://support.microsoft.com/kb/257824/EN-US/
)
OL2000: Differences Between Outlook and Outlook Express SYMPTOMS
When you attempt to retrieve e-mail with Outlook Express 5 for Macintosh from a server that does not contain any messages for you, you may receive the following error message:
Error: -16999
CAUSE
This error message is generated when there is no mail on the server.
RESOLUTION
This error message does not indicate an issue. You can safely ignore the error message. NOTE: This issue is fixed in Microsoft Outlook Express version 5.02. STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. MORE INFORMATION
Outlook Express 5 for Macintosh uses an UIDL request to determine whether a server has mail. In some instances, the server responds with an empty list if there is no mail.
If there are no messages when a client sends an UIDL request, the server should not return "-ERR." The server should return "+OK" with an empty list (just a period to state "end of UIDL list"). For example:
Send data (6 bytes).
Some servers respond with the "-ERR" message, which triggers the "Error: -16999" error message in Outlook Express. The error message does not occur if there are messages on the server.
<000000B0> UIDL Receive data (8 bytes). <0000007C> +OK <00000081> . | Article Translations
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