Help and Support

Article ID: 261156 - Last Review: January 27, 2007 - Revision: 3.1

General Protection Fault in Module Gdi.exe Printing from Internet Explorer

This article was previously published under Q261156

On This Page

Expand all | Collapse all

SYMPTOMS

When you print from Internet Explorer with a Hewlett-Packard (HP) DeskJet 932C or 952C printer, you may receive a general protection (GP) fault in module Gdi.exe.

CAUSE

The Hewlett-Packard drivers for these printers are not compatible with the HTML rendering engine that is used in the products listed at the beginning of this article.

RESOLUTION

To resolve this issue, use the appropriate method.

Method 1

There maybe a conflict that is caused by the installation of the bonus software on the computer.
  1. Uninstall the HP bonus software by using the Add/Remove Programs tool in Control Panel. The Bonus software includes:
    By Design Home
    HP Print creator
    HP Cartogra
    HP Instant Delivery
  2. Uninstall the printer driver.
  3. Restart the computer.
  4. Install the printer driver without the bonus software.

Method 2

  1. Uninstall the printer driver.
  2. Download and install the corporate version of the driver.

Method 3

Use a compatible printer driver such as the HP 550C printer driver when you print from Internet Explorer. According to HP, the printer should still be able to print over the USB connection, but may have to specify the USB port as the port in the printer's properties.

WORKAROUND

To work around this issue, uninstall the HP DeskJet 932C or 952C printer, and then install the HP DeskJet 870CSe drivers by using the Add Printer Wizard. The 870CSe drivers are included with Microsoft Windows 98, Windows 98 Second Edition, and Microsoft Windows 2000. Microsoft Windows 95 users should contact Hewlett-Packard for assistance in obtaining these drivers.

APPLIES TO
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Windows 98 Second Edition
Keywords: 
kberrmsg kbprb kbprint KB261156
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Article Translations

 

Related Support Centers