Help and Support

Article ID: 261276 - Last Review: January 27, 2007 - Revision: 3.4

Parallel Direct Cable Connection Drops Shortly After Connecting

This article was previously published under Q261276

On This Page

Expand all | Collapse all

SYMPTOMS

When your direct cable connection through a parallel port has been inactive for 20 to 40 seconds, the connection may be disconnected. Note that this problem only occurs when you use a parallel port for direct connection from your Windows 98/95-based computer to a Windows 2000-based computer.

CAUSE

The problem is caused by a failure in the Windows 2000 parallel port driver.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack
The English version of this fix should have the following file attributes or later:
   Date        Time        Size     File name
   -----------------------------------------
   06/22/2000  08:24p      17,680   Ptilink.sys
				


WORKAROUND

To work around this problem, use either of the following methods:

Method 1

Use a serial port instead of a parallel port for the direct cable connection.

Method 2

Use a batch file to continuously ping the Windows 2000 host from the connecting guest. A continuous ping can be performed by using the -t switch and specifying the IP address of the Windows 2000 Host. The IP address of the Windows 2000 host could be the assigned address of a connected network adapter, or the first address in the configured pool of addresses for connecting clients.

For example:

pool = 192.186.1.1 to 192.168.1.3

Use the command:
ping -t 192.168.1.1

STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows 2000. This problem was first corrected in Windows 2000 Service Pack 2.

MORE INFORMATION

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149  (http://support.microsoft.com/kb/249149/EN-US/ ) Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbnetwork kbwin2000presp2fix KB261276

Article Translations

 

Related Support Centers