Help and Support

Possible Data Loss After You Enable the "Write Cache Enabled" Feature

Article ID:281672
Last Review:October 27, 2006
Revision:6.2
This article was previously published under Q281672
On This Page

SYMPTOMS

When you enable write caching on a hard disk, the hard disk receives the synchronize cache command when you shut down the computer, and the cached data is written to the hard disk before the computer shuts down. However, when you shut down the computer after the first shutdown, the hard disk does not receive the synchronize cache command and does not write the cached data to the hard disk before the computer shuts down. Note that this occurs even though write caching is enabled. When this problem occurs, you may experience data loss or you may receive an error message on a blue screen.

Back to the top

CAUSE

This problem may occur if the Windows 2000 hard disk driver does not correctly process write caching.

Back to the top

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack
The English-language version of this fix should have the following file attributes or later:
   GMT-UTC Date Time   Version        Size    File name
   -------------------------------------------------------
   16-Nov-2001  17:23  5.0.2195.4643  34,416  Classpnp.sys
   14-Dec-2001  22:12  5.0.2195.4771  29,968  Disk.sys
				

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

Back to the top

MORE INFORMATION

Because the synchronize cache command is sent to only small computer system interface (SCSI) devices, the problem described in this article applies only to SCSI devices.

Some IDE devices that are connected over a SCSI interface are also affected by this issue. For example, Promise Ultra IDE devices are connected over a SCSI interface card. In this case, the synchronize cache command is sent to the device driver that controls the IDE device, and that device driver has to convert the SCSI command to the equivalent IDE command.

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 (http://support.microsoft.com/kb/265173/EN-US/) The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:
296861 (http://support.microsoft.com/kb/296861/EN-US/) How to Install Multiple Windows Updates or Hotfixes with Only One Reboot
For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 (http://support.microsoft.com/kb/249149/EN-US/) Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

Back to the top

How to Enable Write Caching

1.Right-click My Computer, and then click Properties.
2.Click the Hardware tab, and then click Device Manager.
3.Double-click the Disk drives branch to expand it.
4.Right-click the hard disk with which you want to work, and then click Properties.
5.On the Disk Properties tab, click to select the Write Cache Enabled check box, and then click OK.

Back to the top


APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Professional Edition
Microsoft Windows 2000 Advanced Server

Back to the top

Keywords: 
kbhotfixserver kbqfe kbbug kbenv kbfix kboswin2000fix kbwin2000presp3fix kbwin2000sp3fix KB281672

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.