Article ID: 284013 - Last Review: May 14, 2007 - Revision: 2.4

Error Message: The Command REGSVR32 /S CDOWFEVT.DLL Failed

This article was previously published under Q284013
Expand all | Collapse all

SYMPTOMS

If you install SharePoint Portal Server, the installation may fail, and the following error message may be logged in the Exchange Server Setup Progress.log file that is located in the root of the drive that you installed SharePoint Portal Server to:
The command regsvr32 /s cdowfevt.dll failed, returning error code 5 (Access is denied).

ScCreateProcess (J:\Admin\Src\Libs\Exsetup\Hiddenw1.cxx:1763)

Error code 0XC103798A (31114): An internal component has failed.

CAUSE

This issue can occur if the COM+ component service is not installed properly.

RESOLUTION

To resolve this issue, first confirm that the problem is related to COM+:
  1. Check Comsetup.log that is located in the Winnt folder for any error messages.
  2. Ensure COM+ Event system and Microsoft Distributed Transaction Coordinator (MSDTC) services are running.
  3. Check the System Event log for any errors that are related to the services listed in step two.
  4. Enumerate any COM+ packages on your server to verify that COM+ is working.

    To do so, open Administrative Tools, click Component Services, and then expand the tree.
If you receive an error message when you perform step four, you must reset the COM+ service.

For additional information about how to reset the COM+ service, click the article number below to view the article in the Microsoft Knowledge Base:
246499  (http://support.microsoft.com/kb/246499/EN-US/ ) PRB: COM+ Setup Problems While Upgrading to Windows 2000

APPLIES TO
  • Microsoft SharePoint Portal Server 2001
Keywords: 
kbprb KB284013
 

Article Translations

 

Related Support Centers