Takenreeks mislukt in Configuration Manager als software-updates meerdere herstarts vereisen
Dit artikel bevat de informatie voor het oplossen van het probleem dat de taakreeksomgeving niet gevonden fout optreedt bij het gebruik van een Configuration Manager takenreeks.
Oorspronkelijke productversie: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager, Configuration Manager (current branch)
Origineel KB-nummer: 2894518
Samenvatting
Het probleem is opgelost in cumulatieve update 3 voor System Center 2012 Configuration Manager Service Pack 2 en System Center 2012 R2 Configuration Manager Service Pack 1 en in Configuration Manager huidige vertakkingsversie 1602.
Een nieuwe optionele takenreeksvariabele, SMSTSWaitForSecondReboot
, is beschikbaar om het gedrag van de client beter te beheren wanneer een software-update-installatie twee herstarts vereist.
Zie de sectie Software-updatesbeheer/besturingssysteemimplementatie in Beschrijving van cumulatieve update 3 voor Configuration Manager voor meer informatie.
Zie Takenreeksvariabelen voor Configuration Manager huidige vertakking.
Symptomen
Stel dat een Configuration Manager takenreeks die gebruikmaakt van de stap Software installeren Updates een software-update installeert die meerdere herstarts activeert nadat de takenreeks de taak Software installeren Updates heeft uitgevoerd. In deze situatie kan de takenreeks mislukken en het volgende foutbericht genereren:
Takenreeksomgeving niet gevonden
Opmerking
U kunt dit probleem in Configuration Manager voorkomen met behulp van de nieuwe optie Opnieuw proberen in de takenreeksstap Software installeren Updates.
Oorzaak
De eerste herstart die door de software-update wordt gestart, wordt bepaald door de takenreeks. De tweede aanvraag voor opnieuw opstarten wordt echter gestart door een Windows-onderdeel (meestal Component-Based Servicing) en wordt niet beheerd door de takenreeks. Daarom wordt de uitvoeringsstatus van de takenreeks niet opgeslagen vóór het opnieuw opstarten, omdat de tweede herstart niet wordt bepaald door de takenreeks. Wanneer de takenreeks wordt hervat na de tweede herstart, is er geen status beschikbaar om door te gaan.
Oplossing
Om dit probleem op te lossen, raden we u aan om updates waarvoor dubbel opnieuw opstarten is vereist, toe te passen met behulp van de gebruikelijke software-updatesfunctie van Configuration Manager in plaats van takenreeksen te gebruiken. Van de volgende software-updates is gemeld dat ze meerdere herstarts vereisen.
- 3126446 MS16-017: Beschrijving van de beveiligingsupdate voor extern bureaublad-beeldschermstuurprogramma: 9 februari 2016
- 3096053 update van de onderhoudsstack van september 2015 voor Windows 8 en Windows Server 2012
- 3075222 MS15-082: Beschrijving van de beveiligingsupdate voor RDP in Windows: 11 augustus 2015
- 3067904 MS15-082: Beschrijving van de beveiligingsupdate voor Windows RDP: 14 juli 2015
- 3069762 MS15-067: Beschrijving van de beveiligingsupdate voor Windows RDP: 14 juli 2015
- 3003729 update van de onderhoudsstack van april 2015 voor Windows 8 en Windows Server 2012
- 3035017 MS15-030: Beschrijving van de beveiligingsupdate voor extern bureaublad-protocol: 10 maart 2015
- 3039976 MS15-030: Beveiligingsprobleem in Extern bureaublad-protocol kan leiden tot Denial of Service: 10 maart 2015
- 3036493 MS15-030: Beschrijving van de beveiligingsupdate voor extern bureaublad-protocol: 10 maart 2015
- 3003743 MS14-074: Beveiligingsprobleem in Extern bureaublad-protocol kan leiden tot het omzeilen van beveiligingsfuncties: 11 november 2014
- 2984976 RDP 8.0-update voor beperkt beheer in Windows 7 of Windows Server 2008 R2
- 2981685 Beveiligingsupdates kunnen niet worden geïnstalleerd als BitLocker niet op uw computer is geïnstalleerd
- 2966034 Beschrijving van de beveiligingsupdate voor extern bureaublad-beveiligingsrelease voor Windows 8.1-systemen waarop de 2919355 update niet is geïnstalleerd: 10 juni 2014
- 2965788 MS14-030: Beschrijving van de beveiligingsupdate voor Extern bureaublad-beveiligingsupdate voor Windows: 10 juni 2014
- 2920189 Beschrijving van het updatepakket van ingetrokken niet-compatibele UEFI-modules: 13 mei 2014
- 2862330 MS13-081: Beschrijving van de beveiligingsupdate voor USB-stuurprogramma's: 8 oktober 2013
- 2871777 Er is een onderhoudsstackupdate beschikbaar voor Windows RT, Windows 8 en Windows Server 2012: september 2013
- 2871690 Microsoft-beveiligingsadvies: update om niet-compatibele UEFI-opstartlaadprogramma's in te trekken
- 2821895 Er is een onderhoudsstackupdate beschikbaar voor Windows RT en Windows 8: juni 2013
- 2771431 Er is een onderhoudsstackupdate beschikbaar voor Windows 8 en Windows Server 2012
- 2545698 Tekst in sommige kernlettertypen wordt wazig weergegeven in Internet Explorer 9 op een computer met Windows Vista, Windows Server 2008, Windows 7 of Windows Server 2008 R2
- 2529073 Binaire bestanden in sommige USB-stuurprogramma's niet worden bijgewerkt nadat u Windows 7 SP1 of Windows Server 2008 R2 SP1 hebt geïnstalleerd
Meer informatie
Omdat deze tweede herstart niet wordt bepaald door de takenreeks, wordt er geen uitvoeringsstatus opgeslagen vóór het opnieuw opstarten. Wanneer de takenreeks wordt hervat na het opnieuw opstarten, is er geen status beschikbaar om door te gaan. Bovendien kan het volgende bericht worden vastgelegd in het Smsts.log-bestand wanneer u dit probleem ondervindt:
!sVolumeID.empty(), HRESULT=80004005
!sTSMDataPath.empty(), HRESULT=80070002
TS::Utility::GetTSMDataPath( sDataDir ), HRESULT=80070002
Kan de logboekmap niet instellen. Sommige uitvoeringsgeschiedenis kan verloren gaan.
Het systeem kan het opgegeven bestand niet vinden. (Fout: 80070002; Bron: Windows)
Takenreeks uitvoeren
!sVolumeID.empty(), HRESULT=80004005
!sTSMDataPath.empty(), HRESULT=80070002
Takenreeksomgeving niet gevonden
Bovendien kunnen clients waarop releaseversies worden uitgevoerd die ouder zijn dan Microsoft System Center 2012 Configuration Manager Service Pack 1, de volgende logboekvermelding bevatten:
Takenreeks voltooid in Windows PE.
De clientcomputer kan ook vastlopen in de inrichtingsmodus nadat de takenreeks is mislukt. Controleer de registersubsleutel om te bepalen of de computer zich in de HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM\CcmExec
inrichtingsmodus bevindt.
ProvisioningMode
moet worden ingesteld op onwaar. Als deze is ingesteld op true, gebruikt u een van de volgende methoden om de client uit de inrichtingsmodus te halen:
Gebruik de WMI-methode
SetClientProvisioningMode
(Windows Management Instrumentation) om de client correct uit de inrichtingsmodus te halen. De eenvoudigste manier om dit te doen, is door de volgende Windows PowerShell opdracht uit te voeren:Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
Of voer de volgende opdracht uit bij een opdrachtprompt met verhoogde bevoegdheid:
powershell Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
Installeer de client opnieuw.
Belangrijk
Probeer de client niet te herstellen door de waarde van ProvisioningMode
te wijzigen in onwaar. Met deze actie wordt de inrichtingsmodus van de client niet volledig uitgeschakeld.
Feedback
https://aka.ms/ContentUserFeedback.
Binnenkort beschikbaar: In de loop van 2024 zullen we GitHub-problemen geleidelijk uitfaseren als het feedbackmechanisme voor inhoud en deze vervangen door een nieuw feedbacksysteem. Zie voor meer informatie:Feedback verzenden en weergeven voor