Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Pri pokuse o návštevu webovej lokality Windows Update alebo Microsoft Update sa môže zobraziť chybové hlásenie podobné nasledovnému:

Číslo chyby: 0x8DDD0002To inštalovať položky z lokality Windows Update, musíte byť prihlásení ako správca alebo člen skupiny Administrators. Ak je počítač pripojený k sieti, vykonaniu tohto postupu môže tiež zabrániť nastavenie sieťovej politiky.

Toto hlásenie sa zobrazí, aj keď ste prihlásení ako správca alebo člen skupiny Administrators. Poznámka: Ďalšie informácie o lokality Windows Update a Microsoft Update nájdete v časti "Ďalšie informácie".

Príčina

Toto správanie môže vyskytnúť niektorý z nasledujúcich dôvodov:

  1. Nie ste prihlásení ako používateľ patrí do lokálnej skupiny Administrators.

  2. Nemáte povolenie na kľúče databázy registry špecifické alebo priečinky.

  3. Operačný systém nemôže čítať údaje v priečinku %Systemroot%\System32\Catroot2.

Riešenie

Dôležité upozornenie: Táto časť, postup alebo úloha obsahuje kroky, ktoré informujú o úpravách databázy Registry. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Postupujte preto presne podľa týchto krokov. Na dosiahnutie lepšej ochrany zálohujte databázu Registry pred úpravou. Potom môžete obnoviť databázu Registry, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy Registry získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

322756 Zálohovanie a obnovovanie databázy Registry v systéme WindowsAk chcete vyriešiť tento problém, použite jeden z nasledujúcich postupov. Ak metóda 1 nevyrieši problém, použite metódu 2.

  • Metóda 1Skontrolujte, či ste prihlásení ako používateľ patrí do lokálnej skupiny Administrators. Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajtetext nusrmgr.cpla kliknite na tlačidlo OK otvorte okno používateľské kontá . Ak ste členom sieťovej domény, postupujte nasledovne:

    1. V okne Používateľské kontá , kliknutím vyberte konto v zozname a kliknite na položku Vlastnosti.

    2. Na kartu Členstvo v skupine , aby ste overili v skupine Administrators.

    Ak nie sú súčasťou sieťovej domény, v okne Používateľské kontá kliknite na konto a potom skontrolujte, či Správca počítača sa zobrazí v časti názov konta. Po prihlásení ako správca, skúste znova navštívte webovú lokalitu Windows Update alebo Microsoft Update. Ak problém vyriešený, nepokračujte, riešenia problémov.

  • Metóda 2Odstránenie dočasných internetových súborov. Ak to chcete urobiť, postupujte nasledovne:

    1. Otvorte okno Programu Internet Explorer , Nástrojea kliknite na položku Možnosti siete Internet.

    2. V okne Možnosti siete Internet kliknite na karte Všeobecné v časti dočasné internetové súbory, kliknite na položku Odstrániť súborya kliknite na tlačidlo OK.

    Skúste znova navštívte webovú lokalitu Windows Update alebo Microsoft Update. Ak problém vyriešený, nepokračujte, riešenia problémov.

  • Metóda 3Skontrolujte povolenia pre kľúče databázy registry, ktoré používa klienta Windows Update a Microsoft Update klienta.

    1. Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte príkaz regedit a potom kliknite na tlačidlo OK.

    2. Vyhľadajte a vyberte nasledujúci kľúč databázy registry:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate

    3. V ponuke úpravy kliknite na položku povolenia, kliknite na tlačidlo Pridaťa zadajte každý v zobrazenom dialógovom.

    4. Kliknite na tlačidlo Skontrolovať názvya potom kliknite na tlačidlo OK.

    5. Každý vyberte v zozname skupinu alebo používateľa názvy .

    6. Všetkých používateľov, kliknutím začiarknite políčko Úplný prístup v stĺpci Povoliť . Všimnite si, že čítanie v stĺpci Povoliť teraz aj políčko.

    7. Skontrolujte, či žiadne políčka v stĺpci zakázať vyberte každého používateľa v poradí, v zozname skupinu alebo používateľa názvy . Kliknutím zrušte začiarknutie všetkých políčok, v stĺpci zakázať vybraté.

    8. Kliknite na položku Rozšírenéa začiarknite políčka pre všetky podradené objekty nahradiť zobrazenými položkami , kliknite na tlačidlo OK.

    9. Ak sa zobrazí výzva na potvrdenie, a kliknite na tlačidlo OK zatvorte dialógové okno, kliknite na tlačidlo Áno .

    Skúste znova navštívte webovú lokalitu Windows Update alebo Microsoft Update. Ak problém vyriešený, nepokračujte, riešenia problémov.

  • Metóda 4Skontrolujte povolenia pre priečinok štruktúra, klient služby Windows Update alebo Microsoft Update klienta.

    1. Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte explorera kliknite na tlačidlo OK.

    2. Rozbaľte môj počítač, rozbaľte Systémovej jednotkya potom rozbaľte položku WINDOWS.

    3. Kliknite pravým tlačidlom myši na SoftwareDistributiona kliknite na položku Vlastnosti.

    4. V okne SoftwareDistribution vlastnosti kliknite na kartu zabezpečenie a potom overte, či sa v zozname skupinu alebo používateľa názvy .

    5. Vyberte každýv zozname skupinu alebo používateľa názvy . Všetkých používateľov, kliknutím začiarknite políčko Úplný prístup v stĺpci Povoliť . Všimnite si, že čítanie v stĺpci Povoliť teraz aj políčko.

    Skúste znova navštívte webovú lokalitu Windows Update alebo Microsoft Update. Ak problém vyriešený, nepokračujte, riešenia problémov.

  • Metóda 5Premenujte priečinok Catroot2. Chcete urobiť, zadajte nasledovné príkazy do príkazového riadka, stlačením klávesu ENTER po každom riadku:

    net stop cryptsvcRen %systemroot%\system32\catroot2 oldcatroot2net start cryptsvcPokúste sa znova navštívte webovú lokalitu Windows Update alebo Microsoft Update. Ak problém vyriešený, nepokračujte, riešenia problémov.

  • Postup 6Premenovanie priečinka SoftwareDistribution. Chcete urobiť, postupujte nasledovne.

    1. Reštartujte počítač v núdzovom režime.

    2. Vyhľadajte a premenujte Drive: \Windows\SoftwareDistribution priečinok SoftwareDistribution.old. Poznámka: Je zástupný symbol pre systémovú jednotku.

    3. Reštartujte počítač v normálnom režime.

Ďalšie informácie

Musíte byť lokálneho správcu, navštívte webovú lokalitu Windows Update alebo Microsoft Update. Pri prihlásení ako non-správca sa nedá na webovej lokalite aj v prípade, že používate Spustiť program Internet Explorer spustiť pod kontom správcu. Tento problém sa vyskytuje, pretože ďalšie systémové služby do procesu. Ďalšie informácie získate po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:

326686 sa zobraziť chybové hlásenia, keď správca systému zakáže službu Windows Update alebo Microsoft Update

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×