Help and Support
 

powered byLive Search

PCMCIA Cards Not Detected on Zenith NoteFLEX

Article ID:129812
Last Review:November 15, 2006
Revision:1.1
This article was previously published under Q129812
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, you should first make a backup copy of the registry files (System.dat and User.dat). Both are hidden files in the Windows folder.

SYMPTOMS

When you are using a Zenith NoteFLEX 486DX computer with a PCIC-compatible controller (with a Cirrus Logic chip set), PCMCIA cards are not enumerated when you insert them. PCMCIA cards are enumerated only if they are already inserted when you start your computer.

Back to the top

CAUSE

There is a known problem with the automatic detection of available IRQs on the Zenith NoteFLEX computer. As a result, Windows 95 assigns a default set of IRQs for its mask. Although IRQ 10 is in the default mask assigned by Windows 95, IRQ 10 is not supported on NoteFLEX computers.

Back to the top

RESOLUTION

To work around this problem, use Registry Editor (REGEDIT) to add the following registry entry. This entry overrides the default mask:
   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\PCMCIA\0000
				
Add a key called PCICOptions to the entry, and assign the following value for the key:
   b8 0a 00 00
				
For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

Back to the top


APPLIES TO
Microsoft Windows 95

Back to the top

Keywords: 
KB129812

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.