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Unable to Restore cc: Mail After Opening .wri File

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:132790
Last Review:November 15, 2006
Revision:1.1
This article was previously published under Q132790

SYMPTOMS

When you open a file with a .wri extension from cc:Mail version 2.1, WordPad starts automatically, and the cc:Mail window is minimized, but you are unable to restore the cc:Mail window after closing WordPad.

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CAUSE

When you run a .wri file from cc:Mail, cc:Mail attempts to run the program that the .wri extension is associated with, and the cc:Mail window is minimized. Even after you upgrade to Windows 95, the following line, found in the [extensions] section of the Win.ini file, causes .wri files to be associated with Write.exe:
   wri=write.exe ^.wri
				
However, in Windows 95, Write.exe has been replaced with a program stub that starts WordPad (Wordpad.exe). Therefore, when you open a .wri file from cc:Mail in Windows 95, Write.exe starts, which in turn starts WordPad. When you then quit WordPad, the Write.exe stub remains in memory. Because the original program run from cc:Mail, Write.exe, has not been closed, the cc:Mail window is not automatically restored. In fact, the cc:Mail window cannot be restored until the Write.exe program is closed.

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RESOLUTION

Modify the [extensions] section of the Win.ini file so that the line that reads
   wri=write.exe ^.wri
				
reads:
   wri=c:\progra~1\access~1\wordpad.exe ^.wri
				
NOTE: Changing the program that .wri files are associated with in Windows Explorer does not correct this problem.

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MORE INFORMATION

cc:Mail is manufactured by cc:Mail, Inc., a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

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APPLIES TO
Microsoft Windows 95

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Keywords: 
kbappcompatibility KB132790

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