Compression Agent Detects Errors Even After Running ScanDisk This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
This article was previously published under Q140431 SYMPTOMS
When you try to recompress a disk with Compression Agent, you may receive
one of the following error messages:
- Compression Agent cannot recompress this drive because it contains
errors that must first be repaired. Click Help, carry out the
instructions for repairing the errors, and then try again.
- Compression Agent could not finish recompressing the drive because
there was an error. ID No: CMPAGENT103
The same error message may occur again even if you run ScanDisk and
correct the errors on the disk before running Compression Agent again.
CAUSE
This behavior can occur if the compressed drive contains unreliable
clusters that ScanDisk cannot detect.
RESOLUTION
Configure ScanDisk to detect disk timeouts while performing a surface
scan, and then run ScanDisk from a command prompt. To do so, follow these
steps:
MORE INFORMATION
The "ScanTimeOut=On" entry causes ScanDisk to detect disk timeouts while
performing a surface scan. This allows ScanDisk to detect marginal
clusters that are not reliable enough to store data. These clusters are
detected by Compression Agent when you attempt to recompress your files,
but they are not normally detected by ScanDisk.
Additional qeury words: 95
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