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Compression Agent Detects Errors Even After Running ScanDisk

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:140431
Last Review:January 19, 2007
Revision:1.2
This article was previously published under Q140431

SYMPTOMS

When you try to recompress a disk with Compression Agent, you may receive one of the following error messages:
- Compression Agent cannot recompress this drive because it contains errors that must first be repaired. Click Help, carry out the instructions for repairing the errors, and then try again.
- Compression Agent could not finish recompressing the drive because there was an error. ID No: CMPAGENT103
The same error message may occur again even if you run ScanDisk and correct the errors on the disk before running Compression Agent again.

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CAUSE

This behavior can occur if the compressed drive contains unreliable clusters that ScanDisk cannot detect.

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RESOLUTION

Configure ScanDisk to detect disk timeouts while performing a surface scan, and then run ScanDisk from a command prompt. To do so, follow these steps:
1.Click the Start button, click Shut Down, click the "Restart the computer in MS-DOS mode" option, and then click Yes.
2.Type the following line, and then press ENTER:
edit c:\windows\command\scandisk.ini
3.Add the following line to the [Environment] section of the file:
ScanTimeOut=On
4.Save the Scandisk.ini file, and then exit the editor.
5.Type the following line and then press ENTER to run ScanDisk:
scandisk
Run a surface scan when ScanDisk prompts you to do so.
6.Repair any errors that ScanDisk finds.
7.When ScanDisk is finished, type exit and then press ENTER.
8.Run Compression Agent again.

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MORE INFORMATION

The "ScanTimeOut=On" entry causes ScanDisk to detect disk timeouts while performing a surface scan. This allows ScanDisk to detect marginal clusters that are not reliable enough to store data. These clusters are detected by Compression Agent when you attempt to recompress your files, but they are not normally detected by ScanDisk.

Additional qeury words: 95

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APPLIES TO
Microsoft Windows 95
Microsoft Plus! 95 Standard Edition

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Keywords: 
kberrmsg KB140431

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