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Locking Error or Computer Hangs Accessing Network Database Files

Article ID:142803
Last Review:November 15, 2006
Revision:1.1
This article was previously published under Q142803

SYMPTOMS

A program that accesses a database on a Windows 95 or Microsoft Windows NT server (or other SMB server) may exhibit the following behavior:
The program appears to stop responding (hang).
The program returns an error message stating that it was unable to lock a data file.

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CAUSE

These problems can occur if two programs are running on the same computer and they both attempt to access the same database. The problems occur because the network redirector routine used for unlocking the file and holding a new pending lock does not work correctly in a multithreaded environment.

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RESOLUTION

This issue is resolved by the following updated file for Windows 95:
   Vredir.vxd version 4.00.954 (10/10/95) and later.
				
To install this update, follow these steps:
1.Download the Vrdrupd.exe file from the online service listed below to an empty folder.
2.In My Computer or Windows Explorer, double-click the Vrdrupd.exe file you downloaded in step 1.
3.Follow the instructions on the screen.
The following file(s) are available for download from the Microsoft Software Library:
ftp://ftp.microsoft.com/softlib/mslfiles/vrdrupd.exe (ftp://ftp.microsoft.com/softlib/mslfiles/vrdrupd.exe)
For more information about downloading files from the Microsoft Software Library, please see the following article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/EN-US/) How to Obtain Microsoft Support Files from Online Services

The following files are installed by Vrdrupd.exe:
   File name     Version    Date/Time        Size     Destination folder
   ---------------------------------------------------------------------
   Vredir.vxd    4.00.1116  6/2/97  11:16a   156,773  Windows\System
   Vnetsup.vxd   4.00.1112  5/30/97 11:12a    17,595  Windows\System
				

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STATUS

This issue is resolved in Microsoft Windows 98.

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MORE INFORMATION

For additional information about issues resolved by updates to this component, please see the following articles in the Microsoft Knowledge Base:
172594 (http://support.microsoft.com/kb/172594/EN-US/) Cannot Connect to Server with 15 Characters and Period in Name

165402 (http://support.microsoft.com/kb/165402/EN-US/) Windows 95 Update to Encrypt Passwords in Memory

161100 (http://support.microsoft.com/kb/161100/EN-US/) File May Be Truncated When Copied to a Full Network Drive

157114 (http://support.microsoft.com/kb/157114/EN-US/) "Access Denied" Attempting to Run File on LM/X Server

152186 (http://support.microsoft.com/kb/152186/EN-US/) Possible Network Data Corruption If Locking Not Used

148367 (http://support.microsoft.com/kb/148367/EN-US/) Possible Network File Corruption with Redirector Caching

140558 (http://support.microsoft.com/kb/140558/EN-US/) Deleting Files on Samba Servers May Delete Local Files Instead

138249 (http://support.microsoft.com/kb/138249/EN-US/) Updated Vredir.vxd Corrects Errors Running Files on LMX

160807 (http://support.microsoft.com/kb/160807/EN-US/) Cannot Connect to Windows NT Server with Many Shares

150215 (http://support.microsoft.com/kb/150215/EN-US/) Disabling Automatic Network Shortcut Resolution

138014 (http://support.microsoft.com/kb/138014/EN-US/) File May Be Truncated to Zero Bytes When Copied Onto Itself

136834 (http://support.microsoft.com/kb/136834/EN-US/) Error Copying Read-Only Files to Core SMB Server
The following programs are known to exhibit the behavior described in this article:
Microsoft Access Replication Manager
Microsoft Visual Basic for Applications and Microsoft Access front-end programs running simultaneously
Microsoft Access and Transporter processes running simultaneously on a Windows 95-based client computer

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APPLIES TO
Microsoft Windows 95

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Keywords: 
kberrmsg KB142803

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