Help and Support

Problems Installing SRAM or Flash Memory Cards in Windows 95

Article ID:142945
Last Review:November 15, 2006
Revision:1.1
This article was previously published under Q142945
On This Page

SYMPTOMS

When you insert a PCMCIA SRAM or Flash memory card into a Windows 95- based computer that has been configured to use protected-mode PCMCIA card drivers, there may be no drive letter in My Computer or Windows Explorer associated with the PCMCIA card. This can occur even though the card seems to be recognized properly and the appropriate driver is installed.

Back to the top

CAUSE

PCMCIA SRAM and Flash memory cards must be installed differently than other cards that use Windows 95 protected-mode drivers.

Back to the top

RESOLUTION

SRAM Cards

To install a PCMCIA SRAM card in Windows 95, the following two entries must be placed in the Config.sys file
   device=c:\<windows>\system\csmapper.sys
   device=c:\<windows>\system\carddrv.exe /slot=<x>
				
where <windows> is the Windows folder and <x> indicates the number of PCMCIA card slots in the computer.

Back to the top

Flash Cards

To install a PCMCIA Flash memory card in Windows 95, the following entries must be placed in the Config.sys file
   device=c:\<windows>\system\csmapper.sys
   device=c:\<windows>\system\carddrv.exe /slot=<x>
   device=c:\<windows>\ms-flash.sys
				
where <windows> is the Windows folder and <x> indicates the number of PCMCIA slots in the computer.

NOTE: The Ms-flash.sys file is not included with Windows 95. This file must be provided by the Flash memory card manufacturer.

Back to the top

MORE INFORMATION

The information in this article applies only to installing SRAM and Flash memory cards. You may still need to partition and format such cards according to the manufacturer's instructions. Please see the documentation provided by the manufacturer.

Note that if you use only protected-mode drivers for these cards, you do not have access to the cards if you boot your computer to a command prompt.

Back to the top


APPLIES TO
Microsoft Windows 95

Back to the top

Keywords: 
KB142945

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.