Help and Support

Removed Device Not Detected by Add New Hardware Wizard

Article ID:158922
Last Review:November 15, 2006
Revision:1.1
This article was previously published under Q158922

SYMPTOMS

When you run the Add New Hardware Wizard, it may not detect a device that has been removed in Device Manager on a multiple-profile user system.

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CAUSE

Removing a Plug and Play device from one profile and leaving it in another causes a flag to be set in the registry to prevent the device from being enumerated on the next startup, and may also cause the Add New Hardware Wizard to bypass the device. The flag exists only in the profile in which the device was removed.

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RESOLUTION

To prevent this problem from occurring, disable the device in Device Manager instead of removing it. To disable a device, click the Disable In This Hardware Profile check box for the device in Device Manager.

To restore (or redetect) the device, remove it from all profiles and then run the Add New Hardware Wizard.

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APPLIES TO
Microsoft Windows 95

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Keywords: 
KB158922

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