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SNMP Entry Point not Found

Article ID:163595
Last Review:November 1, 2006
Revision:1.2
This article was previously published under Q163595

SUMMARY

After you install the Simple Network Management Protocol (SNMP) service on your Windows NT 4.0 Service Pack 2 or later computer you may receive the following error message:
SNMP Error - Entry point not found.
The procedure entry point SnmpSvcGetEnterpriseOID could not be located in the dynamic link library snmpapi.dll
Event Viewer on your Windows NT computer may also log one or more of the following event messages:
Event ID : 7022
Source : Service Control Manager
Description: The SNMP service hung on starting.
-or-
Event ID : 1106
Source : SNMP
Description: The SNMP service is ignoring extension agent dll. C:\winnt\system32\inetmib1.dll because it is missing or misconfigured.
NOTE: If you receive these error messages, the Network Segment counter may not be displayed in Performance Monitor.

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CAUSE

The files you install with the SNMP service are from the original Windows NT installation media and are older than the files supplied with the service pack.

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RESOLUTION

To resolve this issue, you will need to reapply the latest Windows NT service pack to update all the files.

For additional information, please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: 139815 (http://support.microsoft.com/kb/139815/EN-US/)
TITLE : Windows NT Service Packs and OEM drivers

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MORE INFORMATION

Compaq's Insight Manager is one application that requires the SNMP service to be installed and working correctly. Please use the following installation order when working with a computer that is using Insight Manager:
1.Install all required services including SNMP.
2.Before rebooting apply the latest Windows NT Service Pack.
3.Before rebooting apply the appropriate SSD from Compaq.
4.Reboot.
5.Install Insight Manager from Compaq.
Insight Manager is manufactured by Compaq Computer Corp., a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

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APPLIES TO
Microsoft Windows NT Server 4.0, Terminal Server Edition
Microsoft Windows NT Server 4.0 Standard Edition
Microsoft Windows NT Workstation 4.0 Developer Edition

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Keywords: 
kbnetwork KB163595

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