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Windows 95 RPC Does Not Retry Failed Named Pipe Connections

Article ID:168496
Last Review:November 15, 2006
Revision:1.2
This article was previously published under Q168496

SYMPTOMS

Windows 95 clients using Remote Procedure Calls (RPCs) to connect to an endpoint over named pipes may receive the following error message:
The RPC server is unavailable. Do you wish to continue?

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CAUSE

The named pipe connection code in the Windows 95 RPC run-time libraries does not make any retry attempts after a failed named pipe connect.

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RESOLUTION

This issue is resolved by the following updated file for Windows 95 and OSR2, and later versions of this file:
   RPCLTC1.DLL  version 4.00.951  dated 2/13/97  8,192 bytes
				
A version of this file that resolves this problem is included in DCOM95 for Windows 95, version 1.3, and can be downloaded from the following Microsoft Web site:
http://www.microsoft.com/com/dcom/dcom95/dcom1_3.asp (http://www.microsoft.com/com/dcom/dcom95/dcom1_3.asp)

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STATUS

This problem no longer occurs in Windows 98. To resolve this problem, install the current version of Windows. For information about the current version of Windows, visit http://www.microsoft.com/windows (http://www.microsoft.com/windows).

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MORE INFORMATION

The updated RPC stub code has been modified to retry failed named pipe connects up to 20 times. This is identical to the method used in Microsoft Windows NT.

For additional information about Windows 95 updates, please see the following article in the Microsoft Knowledge Base:
161020 (http://support.microsoft.com/kb/161020/EN-US/) Implementing Windows 95 Updates

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APPLIES TO
Microsoft Windows 95

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Keywords: 
kbhotfixserver kbqfe kbapi kberrmsg kbnetwork kbprb kbrpc KB168496

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