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ACC97: Certain ISAM Drivers Not Appearing in Files Of Type Box

Article ID:171955
Last Review:April 23, 2007
Revision:3.3
This article was previously published under Q171955
Moderate: Requires basic macro, coding, and interoperability skills.

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SYMPTOMS

In Microsoft Access 97, you point to Get External Data on the File menu and then Import, but one or more of the following applications do not appear in the Files Of Type list box:
dBASE III
dBASE IV
dBASE V
Text Files
Microsoft Excel
However, if you rerun the Microsoft Office 97 or Microsoft Access 97 setup program, the ISAM drivers for the applications are checked as installed.

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CAUSE

This behavior can be caused by invalid information in the Windows registry, or by a missing or corrupted dynamic-link library (.dll) file.

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RESOLUTION

To resolve this issue, use one of the following methods.

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Method 1

You must uninstall (remove) and then reinstall the ISAM drivers so that they can be reregistered properly. The following steps demonstrate how to remove and then reinstall the dBASE, Text, and Microsoft Excel drivers so that they will appear in the Files Of Type list box:
1.Start the Microsoft Access 97 or the Microsoft Office 97 Professional Edition Setup program by double-clicking the Add/Remove Programs Icon in Control Panel.
2.On the Install/Uninstall tab, select Microsoft Office 97, Professional Edition or Microsoft Access 97 in the list of applications, and then click Add/Remove.
3.When prompted, place your compact disc into the CD-Rom drive and click OK.

NOTE: If you are running setup from a network, you will not need to place the compact disc into the CD-ROM drive.
4.When the first screen of the Setup program appears, click Add/Remove.
5.In the Options box, select Data Access, and then click Change Option.
6.In the Data Access Options box, click Database Drivers, and then click Change Option.
7.Click to clear the check box for each ISAM driver that does not appear in the Files Of Type list box in Microsoft Access, click OK twice, and then click Continue.

NOTE: If the check box for the ISAM driver is unavailable, click Cancel three times, click Exit Setup twice, click OK to exit the Setup Program, and proceed to Step 10.
8.Click Yes when asked if you want to remove the components.
9.After Setup has finished, click OK to the message that the Setup program has completed successfully.
10.While the Add/Remove Program Properties dialog box is still open, start Windows Explorer (or File Manager) and search for the following file names:
    File Name       Import/Export ISAM For
    --------------------------------------
    MSEXCL35.DLL    Microsoft Excel
    MSTEXT35.DLL    Text
    MSXBSE35.DLL    dBASE
					
11.Rename the files. Close Windows Explorer.
12.Repeat steps 2-6 from the beginning of this section.
13.Click to select the check box for each ISAM driver that you want to reinstall.
14.Click OK twice, and then click Continue.
15.When the Setup program has finished updating your system, click OK. Close the Add/Remove Programs Properties box.
16.Return to Microsoft Access and on the File menu, point to Get External Data, and then click Import. The additional ISAM drivers should now appear in the list.

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Method 2

Use the regsvr32.exe utility to manually re-register the ISAM of the missing driver(s). See the following Knowledge Base article for a list of ISAM file names to re-register:
155666 (http://support.microsoft.com/kb/155666/EN-US/) ACC: Troubleshoot "Couldn't Find Installable ISAM" Error
If, after you use either of these methods, the application that you want to import from still does not appear in the list:
1.Rename the files described in Steps 10 and 11 in the "Resolution" section.
2.Repeat Steps 1 through 3 in the "Resolution" section.
3.When the first screen of the Setup program appears, click Reinstall.
4.When the Reinstall process has finished successfully, repeat step 16 in the "Resolution" section.

NOTE: If the application that you want to import from still does not appear in the list, you will need to uninstall Microsoft Access 97 or Microsoft Office 97 Professional Edition and then reinstall the application. For information about how to successfully uninstall and reinstall Microsoft Access 97 or Microsoft Office 97 Professional Edition, please see the following articles in the Microsoft Knowledge Base:
158658 (http://support.microsoft.com/kb/158658/EN-US/) OFF97: How to Completely Remove Microsoft Office 97
163997 (http://support.microsoft.com/kb/163997/EN-US/) ACC97: How to Completely Uninstall Microsoft Access 97
Additionally, this resolution may fail if the original installation of Microsoft Office Standard had the SR-1 patch applied prior to the installation of Microsoft Access. In this instance, applying the SR-1 patch to Microsoft Access should resolve the issue.

For information about obtaining Microsoft Office 97 SR-1, please see the following article in the Microsoft Knowledge Base:
172475 (http://support.microsoft.com/kb/172475/EN-US/) OFF97: How to Obtain and Install MS Office 97 SR-1

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MORE INFORMATION

Steps to Reproduce Behavior


1.Start Microsoft Access 97 and open a new database.
2.On the File menu, point to Get External Data, and then click Import.
3.In the Import box, click the Files Of Type list box.

The application that you want to import from does not appear in the list.
4.Follow steps 2 through 6 in the "Resolution" section.

Note that the ISAM drivers appear to be selected. In some cases, the word "INSTALLED" appears in the list where the file size normally appears.

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REFERENCES

For information about installing the ISAMs included in the ValuPack, please see the following article in the Microsoft Knowledge Base:
162226 (http://support.microsoft.com/kb/162226/EN-US/) ACC97: How to Remove Paradox, Lotus 1-2-3, and Exchange ISAMs

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APPLIES TO
Microsoft Access 97 Standard Edition

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Keywords: 
kbpubtypekc kbinterop kbprb KB171955

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