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Error Message: Error 745: An Essential File Is Missing

Article ID:174579
Last Review:January 20, 2007
Revision:1.2
This article was previously published under Q174579
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to connect to a remote computer by using Dial-Up Networking, you may receive the following error message:
Error 745: An essential file is missing.
Re-install Dial-Up Networking.

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CAUSE

This issue can occur when a Dial-Up Networking dynamic-link library (.dll) file is missing or damaged.

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RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To resolve this issue, remove, and then reinstall Dial-Up Networking:
1.Click Start, point to Settings, and then click Control Panel.
2.Double-click Add/Remove Programs.
3.Click the Windows Setup tab, click Communications, and then click Details.
4.Click to clear the Dial-Up Networking check box, click OK, and then click OK.
5.Click Start, click Shut Down, click Restart Your Computer, and then click Yes.
6.Click Start, point to Programs, and then click Windows Explorer.
7.Look for the Rasapi32.dll file in the Windows\System folder. If it exists, rename the Rasapi32.dll file to Rasapi32.old. To rename a file, right-click it, click Rename, type the new file name, and then press ENTER.
8.Use Registry Editor to check the path value under the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess
\Authentication\SMM_Files\PPP
NOTE: The above registry key is one path; it has been wrapped for readability.

If the path is Rasapi32.dll or Smmscrpt.dll, perform steps 9-15.

If the path is not Rasapi32.dll or Smmscrpt.dll, edit the path by double-clicking the word Path. Change the value to Rasapi32.dll, extract a new copy of the Rasapi32.dll file, reinstall Dial-Up Networking, and then skip the remaining steps.

Extract a new copy of the Rasapi32.dll file from your original Windows 95 or 98 CD-ROM or floppy disks into the Windows\System folder. To do this, use the appropriate method:

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Extracting Rasapi32.dll from the Windows 95 CD-ROM

a. Click Start, point to Programs, and then click MS-DOS Prompt.
b. Type cd\, and then press ENTER.
c. Insert the Windows 95 CD-ROM into the CD-ROM drive, and then close the Windows 95 screen if it appears.
d. Type the following line at the command prompt, and then press ENTER:
extract /a drive:\win95\win95_02.cab rasapi32.dll /l c:\windows\system
where drive is the drive letter assigned to your CD-ROM drive.
e. Type exit, and then press ENTER to return to Windows.

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Extracting Rasapi32.dll from the Windows 95 Floppy Disks

a. Click Start, point to Programs, and then click MS-DOS Prompt.
b. Type cd\, and then press ENTER.
c. Insert disk 10 of the Windows 95 disks into the floppy disk drive.
d. Type the following line at the command prompt, and then press ENTER:
extract /a drive:\Win95_10.cab rasapi32.dll /l c:\windows\system
where drive is the drive letter assigned to the floppy disk drive in which the Windows 95 floppy disk is located.
e. Type exit, and then press ENTER to return to Windows.

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Extracting Rasapi32.dll in Windows 98

Extract a new copy of the Rasapi32.dll file from your original Windows 98 CD-ROM into the Windows\System folder by using the System File Checker tool. To start the System File Checker tool, click Start, click Run, type sfc.exe in the Open box, and then click OK. For more information about using the Extract tool, click Start, point to Programs, click MS-DOS Prompt, type extract, and then press ENTER. For additional information about using the Extract tool or System File Checker, click the article number below to view the article in the Microsoft Knowledge Base:
129605 (http://support.microsoft.com/kb/129605/EN-US/) How to Extract Original Compressed Windows Files
9.Use Registry Editor to delete the SMM_Files key under the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess
\Authentication
10.Click Start, click Settings, and then click Control Panel.
11.Double-click Add/Remove Programs.
12.Click the Windows Setup tab, click Communications (the word, not the check box), and then click Details.
13.Click to select the Dial-Up Networking check box, click OK, and then click OK again.
14.When you are prompted to restart your computer, click Yes.
15.If you had previously installed Dial-Up Scripting in Windows 95, rename the Smmscrpt.dll file in the Windows\System folder, and then reinstall Dial-Up Scripting. For additional information about installing Dial-Up Scripting, click the article number below to view the article in the Microsoft Knowledge Base:
153038 (http://support.microsoft.com/kb/153038/EN-US/) How to Automate Dial-Up Networking Connections

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MORE INFORMATION

To determine the DLL file that is used by Dial-Up Networking, view the Path value under the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess
\Authentication\SMM_Files\PPP
The default value is "Rasapi32.dll." If Dial-Up Scripting is installed in Windows 95, this value may be "Smmscrpt.dll."

CompuServe's WOW! software, which is included with Windows 95 OEM Service Release 2 (OSR2), changes the Path value to "Smmcctb.dll" and adds "CISPPP: PPP connection using CompuServenetworks" to the available server types in the Dial-Up Networking connection properties.

The CompuServe WOW! software should no longer be necessary because CompuServe discontinued the WOW! service as of January 31, 1997.

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APPLIES TO
Microsoft Windows 95
Microsoft Windows 98 Standard Edition
Microsoft Windows 98 Second Edition

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Keywords: 
kbdialup kberrmsg kbfaq kbprb KB174579

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