Help and Support
 

powered byLive Search

FP97: DCOM Update Required for VSS Integration With MSPWS

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:177151
Last Review:April 18, 2003
Revision:2.1
This article was previously published under Q177151

SYMPTOMS

You cannot integrate functionality between Microsoft FrontPage 97 and Microsoft Visual Source Safe on the Microsoft Personal Web Server for Windows 95.

Back to the top

CAUSE

The integration between FrontPage and Visual Source Safe on Microsoft Internet Information Server (IIS), Microsoft Windows NT Workstation Peer Web Services, or Microsoft Personal Web Server for Windows 95 requires functionality that is only present in the Distributed Component Object Model (DCOM).

This capability was introduced in Microsoft Windows NT 4.0 Workstation and Server. It was not originally part of Windows 95. Therefore, FrontPage cannot be integrated with Visual Source Safe on the Microsoft Personal Web Server for Windows 95.

Back to the top

RESOLUTION

To integrate Microsoft FrontPage and Microsoft Visual SourceSafe on the Microsoft Personal Web Server for Windows 95, obtain and install the DCOM update for Windows 95. You can obtain the DCOM update for Windows 95 by connecting to the following Microsoft World Wide Web site:
http://www.microsoft.com/com/dcom/dcom95/dcom1_3.asp (http://www.microsoft.com/com/dcom/dcom95/dcom1_3.asp)
NOTE: The DCOM update is also installed if you install Microsoft Internet Explorer 4.0.

Back to the top

MORE INFORMATION

Microsoft FrontPage 97 does not support DCOM because it was developed after FrontPage 97 was released. FrontPage 97 was not tested with DCOM and it is not supported running under it. FrontPage 98 was developed after the introduction of DCOM and was tested with it and is supported with DCOM.

Back to the top


APPLIES TO
Microsoft FrontPage 97 Standard Edition

Back to the top

Keywords: 
kbinfo kbinterop KB177151

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.