Help and Support

OL98: (CW) Page Fault Errors Resulting from Winsock Update

Article ID:185362
Last Review:August 9, 2004
Revision:2.2
This article was previously published under Q185362
NOTE: The procedures in this article only apply if you have installed Outlook with the Corporate or Workgroup option. With this option, you can use Messaging Application Programming Interface (MAPI) services. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Corporate or Workgroup installation, you see "Corporate or Workgroup".

SYMPTOMS

In Microsoft Outlook 98, when you attempt to send or receive an e-mail message, you may receive the following error:
MAPISP32 caused an invalid page fault in module INETCOMM.DLL at 0157:5e.
In some cases the page fault may occur in module Kernel32.dll and the address given may be different.

Back to the top

CAUSE

This error message may occur if you install the Windows Sockets (Winsock) 2 Update, but do not update Transmission Control Protocol/Internet Protocol (TCP/IP) using the Vipup20.exe and Vtcpup20.exe files.

Back to the top

RESOLUTION

To resolve this behavior, download the Vipup20.exe and Vtcpup20.exe files from the Microsoft Download Center.

The following files are available for download from the Microsoft Download Center:
DownloadDownload Vipup20.exe now (http://download.microsoft.com/download/win95upg/update3/1/w95/en-us/vipup20.exe)

DownloadDownload Vtcpup20.exe now (http://download.microsoft.com/download/win95upg/update4/1/w95/en-us/vtcpup20.exe)
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/EN-US/) How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

To work around this behavior, revert to Winsock 1.1 by uninstalling the Winsock 2 Update. To do this, double-click the Ws2bakup.bat file located in the following folder:
<drive>:\<windows>\ws2bakup
Where <drive> is the drive letter where the Windows folder is located, and <windows> is the name of the folder in which Windows is installed.

Back to the top

REFERENCES

For information about how to obtain the Vipup20.exe and Vtcpup20.exe files from the Microsoft Download Center, please see the following article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/EN-US/) How to Obtain Microsoft Support Files from Online Services
For information on similar errors, please see the following article in the Microsoft Knowledge Base:
174095 (http://support.microsoft.com/kb/174095/EN-US/) IGMP Query Times Out in Windows 95 with Winsock2 Update

Back to the top


APPLIES TO
Microsoft Outlook 98 Standard Edition

Back to the top

Keywords: 
kbdownload kbgraphxlinkcritical kbprb KB185362

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.