Help and Support
 

powered byLive Search

"The registry is corrupted and Windows must be installed to a new directory" error message when you rerun Windows 98 Setup after it stops responding

Article ID:189473
Last Review:January 23, 2007
Revision:1.3
This article was previously published under Q189473

SYMPTOMS

If Windows 98 Setup stops responding (hangs) during the file copy process, and you run Setup again, you may receive the following error message:
The registry is corrupted and Windows must be installed to a new directory.

Back to the top

CAUSE

This error message can occur for any of the following reasons:

Advanced Power Management (APM) shut down your computer during the file copy process.
A program or programs running during the file copy process may conflict with Windows 98 Setup.
There is not enough free space on your hard disk to complete the installation.
You are running the Symantec Norton Utilities Nprotect program (Protected Recycle Bin) during the file copy process.

Back to the top

RESOLUTION

To resolve this issue, follow these steps:
1.Restart your computer. When you see the "Starting Windows 95" message, press the F8 key, and then choose Safe Mode Command Prompt Only from the Startup menu.

For Windows 98, restart your computer, press and hold down the CTRL key after your computer completes the Power On Self Test (POST), and then choose Safe Mode Command Prompt Only from the Startup menu.
2.Type the following lines at the command prompt, pressing ENTER after each command:

cd \windows
attrib -r -s -h system.dat
attrib -r -s -h user.dat
ren system.dat system.bad
ren user.dat user.bad
copy \system.new system.dat
copy \user.new user.dat
cd\
deltree /y recycled
3.Use the appropriate method, and then continue to step 4:

APM shut down your computer
Programs running during the file copy process
Not enough free space on your hard disk
Symantec Norton Utilities Nprotect program is running

Back to the top

APM Shut Down Your Computer

Before you start Windows 98 Setup, disable APM in your computer's BIOS. For information about how to do so, contact the manufacturer of your computer, or view the documentation included with your computer.

Back to the top

Programs Running During the File Copy Process

Before you start Windows 98 Setup, verify that only the necessary drivers or programs in the Config.sys or Autoexec.bat files are being loaded. For information about how to do so, please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: 188867 (http://support.microsoft.com/kb/188867/EN-US/)
TITLE : Troubleshooting Windows 98 Startup Problems

Back to the top

Not Enough Free Space on Your Hard Disk

Before you start Windows 98 Setup, verify that your hard disk has at least 195 megabytes (MB) of free space. For more information about the minimum requirements for Setup, please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: 182751 (http://support.microsoft.com/kb/182751/EN-US/)
TITLE : Minimum Hardware Requirements for Windows 98 Installation

Back to the top

Norton Utilities Nprotect Program Is Running

Before you start Windows 98 Setup, empty, and then disable the Norton Utilities Nprotect program. For information about how to do so, contact Symantec, or view the documentation included with Norton Utilities.
4.Restart your computer. When you see the "Starting Windows 95" message, press the F8 key, and then choose Safe Mode Command Prompt Only from the Startup menu.

For Windows 98, restart your computer, press and hold down the CTRL key after your computer completes the Power On Self Test (POST), and then choose Safe Mode Command Prompt Only from the Startup menu.
5.Run Windows 98 Setup again.

Back to the top

MORE INFORMATION

The third-party product discussed in this article is manufactured by a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

Back to the top


APPLIES TO
Microsoft Windows 98 Standard Edition

Back to the top

Keywords: 
kb3rdparty kbenv kberrmsg kbfaq kbprb kbsetup KB189473

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.