Help and Support

PRB: HTML Help API Fails When Running Under Win 95 and IE 3.02

Article ID:193364
Last Review:February 9, 2006
Revision:2.0
This article was previously published under Q193364

SYMPTOMS

If you try to use HTML Help API commands when running under Windows 95 and Internet Explorer 3.02, the following error message might appear:
No help topics associated with this item.
Or, the command appears to be completely ignored.

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CAUSE

DCOM95 is not installed on the computer.

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RESOLUTION

Do one of the following to resolve this problem:

Install DCOM95, which is available (along with redistribution information) from the following Web site:
http://www.msdn.microsoft.com (http://www.msdn.microsoft.com)
Install Internet Explorer 4.x, which will install the necessary components of DCOM for the HTML Help API, from the following Web site:
http://www.msdn.microsoft.com (http://www.msdn.microsoft.com)

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STATUS

This behavior is by design.

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MORE INFORMATION

To determine whether or not a computer has DCOM installed, check the following registry key:

   HKEY_LOCAL_MACHINE\Software\Microsoft\OLE
				


If DCOM is installed, the registry key will have "EnableDCOM" as a named value. By default this value is should be set to "Y."

NOTE: If you change the registry key's setting, you must restart your computer.

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APPLIES TO
Microsoft HTML Help 1.1

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Keywords: 
kbapi kbdcom kbprb KB193364

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