Help and Support

Date and Time Not Updated During Second Visit to Web Site

Article ID:196329
Last Review:November 5, 2003
Revision:3.0
This article was previously published under Q196329
On This Page

SYMPTOMS

When you return to a Web page that displays date and time information after previously viewing the page, the date and time information may not be correct. Instead, the date and time information may be the same as the first time you viewed the Web page.

Back to the top

CAUSE

This problem can occur if the Web page contains the following Hypertext Markup Language (HTML) source code:

<META HTTP-EQUIV="Expires" CONTENT="Tue, 01 Jan 1980 1:00:00 GMT">
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
				

Back to the top

RESOLUTION

To work around this problem so the correct date and time information is displayed, use either of the following methods:

Back to the top

Method 1

Click Refresh in Internet Explorer. Note that clicking Back and then returning to the Web page does not update the data and time.

Back to the top

Method 2

Prevent the page from being stored in the cache (this forces the page to be reloaded). To do so, add a JScript OnUnload handler that does not do anything. For example, add the following OnUnload handler:

<BODY onUnload="nothing()">
				


where nothing is:

function nothing() {}
				

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Back to the top

MORE INFORMATION

Internet Explorer for Macintosh has an additional cache that is entirely random access memory (RAM) based. This cache holds several of the previous pages (depending on their size) so that clicking Back or Next loads a page very quickly.

Back to the top


APPLIES TO
Microsoft Internet Explorer 4.01 for Macintosh

Back to the top

Keywords: 
kbprb KB196329

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.