Help and Support

FP2000: Browsing Web Returns List of Files Instead of Home Page

Article ID:205479
Last Review:October 1, 2001
Revision:1.0
This article was previously published under Q205479

For a Microsoft FrontPage 98 version of this article, see 194328 (http://support.microsoft.com/kb/194328/EN-US/).
For a Microsoft FrontPage 97 and earlier version of this article, see 143104 (http://support.microsoft.com/kb/143104/EN-US/).

SYMPTOMS

If you browse to a FrontPage Web site that is using the FrontPage Personal Web Server, you may see a list of files in the Web's directory instead of the home page.

Back to the top

CAUSE

This behavior occurs when the FrontPage Personal Web Server cannot find the home page.

The FrontPage Personal Web Server looks for a home page with the file name (Index.htm) that is specified in the Srm.cnf file (located in the server's \conf directory). A page with this file name is displayed by the browser, without the browser requesting a specific page.

If you see a list of files in the directory, the directory does not have a page with the specified file name.

The default file name of the home page for the FrontPage Personal Web Server is Index.htm.

Back to the top

RESOLUTION

To resolve this problem, either rename your home page to Index.htm, or reconfigure the FrontPage Personal Web Server to serve the home page file name that you want.

If you choose to rename your home page, you may need to correct any links in the Web that point back to the home page. In FrontPage 2000, you will be prompted to automatically update incoming links.

NOTE: Other Web servers use different default home page file names, such as Index.html, Welcome.htm, Welcome.html, Default.htm, or Default.html.

Back to the top


APPLIES TO
Microsoft FrontPage 2000 Standard Edition

Back to the top

Keywords: 
kbprb KB205479

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.