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Error Message: An Error Occurred While Windows Was Working with the Control Panel file C:\Windows\System\Desk.cpl.

Article ID:217752
Last Review:January 24, 2007
Revision:2.1
This article was previously published under Q217752
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:
http://support.microsoft.com/default.aspx/w98?sid=460 (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fdefault.aspx%2fw98%3fsid%3d460)
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to change display properties using the Display tool in Control Panel or by right-clicking the Desktop and then clicking Properties, you may receive the following error message:
An error occurred while Windows was working with the Control Panel file C:\Windows\System\Desk.cpl.

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CAUSE

This error message can occur if there is a problem with a third-party video driver or utility.

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RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this error message, start your computer in Safe mode, and then follow these steps:
1.Click Start, point to Settings, click Control Panel, and then double-click Display.
2.Click the Settings tab, and then click Advanced.
3.Click the Adapter tab, and then click Change.
4.Click Next, click Display a list of all the drivers in a specific location, so you can select the driver you want, and then click Next.
5.Click Show All Devices.
6.In the Manufacturers box, click Standard Display Types.
7.In the Models box, click Standard Display Adapter (VGA), click OK, and then click Next.
8.Click Next, click Next, and then click Finish.
9.Click Close, click Close again, and then click No when you are prompted to restart your computer.
10.In Control Panel, double-click Add/remove Programs, and then remove any third-party display utilities by clicking the utility on the Install/Uninstall tab, clicking Add/Remove, and then following the instructions on your screen.
11.Using Registry Editor, delete the display manufacturer's folder (if it exists) in the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Controls Folder\Display\shellex\PropertySheetHandlers
12.You should also delete the following two keys after uninstalling Diamond InControl Tools:
Hkey_local_machine/software/Diamond Multimedia
Hkey_current_user/software/Diamond Multimedia

or

Hkey_local_machine/software/Diamond
Hkey_current_user/software/Diamond
13.Quit Registry Editor and restart your computer.
14.After uninstalling Diamond InControl Tools, extract a new copy of the Deskw95.cpl file from your original Windows 98 CD-ROM to the Windows\System folder. Rename the extracted file to Desk.cpl.

For information about how to extract files, see the following article in the Microsoft Knowledge Base:
129605 (http://support.microsoft.com/kb/129605/EN-US/) How to Extract Original Compressed Windows Files
15.Install the appropriate video drivers included with Windows 98 or obtain the latest drivers from the manufacturer.

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APPLIES TO
Microsoft Windows 98 Standard Edition
Microsoft Windows Millennium Edition

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Keywords: 
kb3rdparty kbdisplay kberrmsg kbprb KB217752

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