Help and Support

FP2000: Saving Office HTML File to a FrontPage Web Results in a Broken Hyperlink

Article ID:219694
Last Review:May 23, 2003
Revision:2.0
This article was previously published under Q219694

SYMPTOMS

When you save an Office HTML file to a FrontPage web, the file appears as a broken link in the Broken Hyperlinks report.

When you preview the page in the browser, the hyperlinks and images on the page work correctly.

Back to the top

CAUSE

When you use the "Save as web page" command, Office documents may create links to "filelist.xml", "editdata.mso", or "oledata.mso" in the HTML document. Because these files are not created, FrontPage cannot resolve the hyperlinks and will report them as broken hyperlinks.

Office applications may generate lines of code in the HTML source of the page that may be similar to the following:
<link rel=File-List href="./filename_files/filelist.xml">
				

<link rel=File-List href="./filename_files/editdata.mso">
				

<link rel=File-List href="./filename_files/oledata.mso">
				

Back to the top

RESOLUTION

Although the page works correctly in the browser, you may use the following method to remove the files from the Broken Hyperlinks Report:
1.In FrontPage, right-click the Office HTML file, and click Open With on the menu.
2.In the Open With Editor dialog box, click to select Text Editor, and click OK.
3.In the Office HTML file, remove the following hyperlink references.
<link rel=File-List href="./filename_files/filelist.xml">
					

<link rel=File-List href="./filename_files/editdata.mso">
					

<link rel=File-List href="./filename_files/oledata.mso">
					

4.On the File menu, click Save.

Back to the top

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

Back to the top


APPLIES TO
Microsoft Excel 2000 Standard Edition
Microsoft FrontPage 2000 Standard Edition
Microsoft Word 2000 Standard Edition
Microsoft PowerPoint 2000 Standard Edition

Back to the top

Keywords: 
kbbug kbnofix KB219694

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.