Help and Support
 

powered byLive Search

Small Business Server Setup May Install Incorrect Intel Network Adapter

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:224984
Last Review:October 3, 2003
Revision:3.0
This article was previously published under Q224984

SYMPTOMS

If you have an Intel 82558-based or 82559-based network adapter installed in your Small Business Server (SBS) computer, Setup detects and installs it as an Intel 82557-based network adapter, which does not work.

Symptoms for the 82558 network adapter include:
The network driver is not initialized and displays a warning that a service has stopped responding.
Event ID 7000 occurs. This event has the following text:
The Intel 82557-based PRO Adapter Driver service does not start because of the following error: A device attached to the system is not functioning.
Event ID 5007 E100B1 occurs. This even has the following text:
Timed out during an operation.

Symptoms for the 82559 network adapter include:
Windows NT stops with an error message displayed on a blue screen during the network driver installation.
Installation is completed properly but the network driver is not initialized.

Back to the top

CAUSE

This behavior occurs because version 2.02 of the E100b.sys driver included on the SBS 4.0 CD-ROM includes controller-specific code that is not compatible with the Intel 82558 and 82559 controllers. This driver and subsequent drivers (through version 2.20) are for use with the Intel 82557 Fast Ethernet controller.

Back to the top

RESOLUTION

To resolve this problem:

1.Click Start, point to Settings, click Control Panel, and then double-click Network.
2.Click the Adapters tab.
3.Click Intel 82557 or MS Loopback Adapter (for the 82559 adapter), and then click Remove.
4.When you are prompted to confirm the removal, click OK.
5.Click Add, and then click Have Disk.
6.Insert the disk containing the network adapter driver.
7.Click OK, and then click the adapter type (Intel 82558 or 82559) in the list of adapters.
8.Click Close. The bindings are reconfigured and the TCP/IP Properties dialog box appears.
9.Click Specify an IP address.
10.In the IP Address box, type 10.0.0.2.
11.In the Subnet Mask box, type 255.255.255.0.
12.Click the WINS Address tab.
13.In the Primary WINS Server and Secondary WINS Server boxes, type 10.0.0.2.
14.Click OK, and then click Yes to restart your computer. Setup continues automatically.
NOTE: These steps delete the Intel 82557 adapter and install an Intel 82558 or 82559 adapter. The 82558 and 82559 adapters use the latest Intel PRO/100+ drivers, which are available from the following Intel Web site:
http://support.intel.com/support/network/ (http://support.intel.com/support/network/)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

These updated drivers are backward compatible with the 82557 adapter.

If you have an Intel 82559 adapter installed in your SBS computer and an error message is displayed on a blue screen during installation or at startup, physically remove the network adapter, and restart your computer. Use Intel Driver Disk Software Release 3.1 or later and the steps outlined above to update the driver. Note: Some motherboards have the network adapter built in. In this situation disable the network adapter in the BIOS and then repeat the install.

NOTE: It may be necessary to install SBS with the network adapter removed from the system. In this case, finish Setup, replace the 82559 network adapter, and restart the server before proceeding with the steps outlined above.

Back to the top

REFERENCES

For additional information, please see the following articles in the Microsoft Knowledge Base:
224800 (http://support.microsoft.com/kb/224800/EN-US/) SBS 4.5 Setup Does Not Automatically Detect 8255x Intel Adapter
224314 (http://support.microsoft.com/kb/224314/EN-US/) Misdetection of Intel PRO/100+ Adapters May Result in Bluescreen

Back to the top


APPLIES TO
Microsoft BackOffice Small Business Server 4.0
Microsoft BackOffice Small Business Server 4.0a

Back to the top

Keywords: 
kbenv kbnetwork kbprb kbsetup KB224984

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.