Small Business Server Setup May Install Incorrect Intel Network Adapter This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
This article was previously published under Q224984 SYMPTOMS
If you have an Intel 82558-based or 82559-based network adapter installed in your Small Business Server (SBS) computer, Setup detects and installs it as an Intel 82557-based network adapter, which does not work.
Symptoms for the 82558 network adapter include:
Symptoms for the 82559 network adapter include:
CAUSE
This behavior occurs because version 2.02 of the E100b.sys driver included on the SBS 4.0 CD-ROM includes controller-specific code that is not compatible with the Intel 82558 and 82559 controllers. This driver and subsequent drivers (through version 2.20) are for use with the Intel 82557 Fast Ethernet controller.
RESOLUTION
To resolve this problem:
http://support.intel.com/support/network/ (http://support.intel.com/support/network/) Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.These updated drivers are backward compatible with the 82557 adapter. If you have an Intel 82559 adapter installed in your SBS computer and an error message is displayed on a blue screen during installation or at startup, physically remove the network adapter, and restart your computer. Use Intel Driver Disk Software Release 3.1 or later and the steps outlined above to update the driver. Note: Some motherboards have the network adapter built in. In this situation disable the network adapter in the BIOS and then repeat the install. NOTE: It may be necessary to install SBS with the network adapter removed from the system. In this case, finish Setup, replace the 82559 network adapter, and restart the server before proceeding with the steps outlined above. REFERENCES
For additional information, please see the following articles in the Microsoft Knowledge Base:
224800 (http://support.microsoft.com/kb/224800/EN-US/) SBS 4.5 Setup Does Not Automatically Detect 8255x Intel Adapter
224314 (http://support.microsoft.com/kb/224314/EN-US/) Misdetection of Intel PRO/100+ Adapters May Result in Bluescreen
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