Help and Support
 

powered byLive Search

Problems in Winsock-based Programs After Internet Explorer Setup

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:230243
Last Review:January 24, 2007
Revision:1.1
This article was previously published under Q230243
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry

SYMPTOMS

After you install Microsoft WebTV and Internet Explorer 5 on your Windows 98-based computer, Winsock-based programs may not work correctly.

Back to the top

CAUSE

This problem can occur because when during WebTV Setup, the following Internet Explorer 5 registry values are modified:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock\Autodial
AutodialAllName32 value: "sddata.dll"
AutodialFcnName32 value: "BPCInternetAutodialHandler"

Back to the top

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this problem, use Registry Editor to modify the following registry information as follows:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock\Autodial
AutodialDllName32 value: change "sddata.dll" to "wininet.dll"
AutodialFcnName32 value: change "BPCInternetAutodialHandler" to "InternetAutodialCallback"

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Back to the top


APPLIES TO
Microsoft Internet Explorer 5.0

Back to the top

Keywords: 
kbenv kbprb kbui KB230243

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.