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OFF2000: Internal Error 2894 During Office or Works Installation

Article ID:236053
Last Review:January 24, 2007
Revision:3.2
This article was previously published under Q236053
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SYMPTOMS

When you install one of the Microsoft products listed at the beginning of this article, you may receive the following error message:
Error 2894. Internal Error 2894: Please contact product support for assistance.
When you click OK, you receive the following error message:
Installation ended prematurely because of an error.

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CAUSE

Cause 1

This problem occurs if an incorrect or damaged (corrupted) version of the Riched20.dll file is on your computer, or if the Riched20.dll file is missing from your computer.

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Cause 2

This problem also occurs if your computer is infected with the Nimda virus (W32.Nimda.A@mm).

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RESOLUTION

Cause 1

To resolve this problem, follow these steps:
1.If you have a copy of Riched20.dll on your computer, locate and rename this file to Riched20.old. Otherwise, continue to step 2.
2.For Microsoft Office: In Windows Explorer, open the Msi folder on your Office 2000 CD.

For Microsoft Works: Open the WordAdd folder on your CD.
3.For Microsoft Office: If your computer is running Microsoft Windows 95 or Microsoft Windows 98, double-click Instmsi.exe. If your computer is running Microsoft Windows NT 4.0 or Microsoft Windows 2000, double-click Instmsiw.exe.

For Microsoft Works: If your computer is running Microsoft Windows 95 or Microsoft Windows 98, double-click Instmsia.exe.
4.Click OK to the message that the Windows Installer installed successfully.
5.Run Setup for Office.

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Cause 2

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
308357 (http://support.microsoft.com/kb/308357/EN-US/) OFF: Setup Error 2889 Caused by Nimda Virus Infection

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MORE INFORMATION

The Windows Installer that is included with Office 2000 installs a version (5.30.11.2410) of Riched20.dll that is more recent than the version that is included with Windows 95, Windows 98, or Windows NT 4.0. If this file is replaced by another program or is deleted, you may experience the error message when you install Office.

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REFERENCES

For more articles about how to troubleshoot specific errors in Office Setup:
Click here to view a list of Windows Installer Errors for Office 2000 articles (http://support.microsoft.com/search/default.aspx?catalog=lcid%3d1033&spid=2484&query=xlwinsetup%2band%2bkberrmsg&adv=&mode=s&cat=false)
For more articles with general information about how to troubleshoot Office errors:
Click here to view a list of Office 2000 Troubleshooting articles (http://support.microsoft.com/search/default.aspx?catalog=lcid%3d1033&spid=2484&query=kbdtatshoot&adv=&mode=s&cat=false)

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APPLIES TO
Microsoft Project 2000 Standard Edition
Microsoft Works Suite 2000
Microsoft Office 2000 Premium Edition
Microsoft Office 2000 Professional Edition
Microsoft Office 2000 Standard Edition
Microsoft Office 2000 Small Business Edition
Microsoft Office 2000 Developer Edition
Microsoft Access 2000 Standard Edition
Microsoft Excel 2000 Standard Edition
Microsoft FrontPage 2000 Standard Edition
Microsoft Outlook 2000 Standard Edition
Microsoft PowerPoint 2000 Standard Edition
Microsoft Word 2000 Standard Edition

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Keywords: 
kberrmsg kbprb kbsetup KB236053

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