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The printer settings may lost when the Name AutoCorrect feature is enabled in Access 2000

Article ID:240826
Last Review:July 28, 2004
Revision:1.0
This article was previously published under Q240826
Moderate: Requires basic macro, coding, and interoperability skills.

This article applies only to a Microsoft Access database (.mdb).

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SYMPTOMS

A Microsoft Access report suddenly is not formatted as expected. Upon checking the printer settings, you find that they have been reset to their default settings.

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CAUSE

This can happen under certain conditions if the Name AutoCorrect feature is enabled.

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RESOLUTION

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:
245025 (http://support.microsoft.com/kb/245025/) How to obtain and install the Microsoft Office 2000 SR-1/SR-1a Update
In the Page Setup dialog box, (on the File menu, click Page Setup) reset the values to the settings that you want.

To avoid this problem, disable Name AutoCorrect by following these steps:
1. On the Tools menu, click Options.
2. In the Options dialog box, click the General tab.
3. Click to clear the Perform name AutoCorrect check box.
4. Click OK.
5.Quit and then restart Access.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Microsoft Office 2000 SR-1/SR-1a.

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MORE INFORMATION

CAUTION: If you follow the steps in this example, you modify the sample database Northwind.mdb. You may want to back up the Northwind.mdb file and follow these steps on a copy of the database.

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Steps to Reproduce Behavior

This issue can occur in the following scenarios.

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Scenario 1

After you compact a database, the printer settings for reports that contain subreports are reset to their default values after the second time that you preview a report.

To reproduce the first scenario, follow these steps:
1. Start Access 2000 and open the sample database Northwind.mdb.
2. On the Tools menu, click Options.
3. On the General tab, make sure that the Perform name AutoCorrect check box is selected. If not, click to select it, and then restart Access.
4. Open the "Sales by Category" report in Design view.
5. On the File menu, click Page Setup.
6. Change all margins to .25".
7. Click the Page tab.
8. Under Orientation, verify that the orientation is set to Landscape.
9. Save and close the report.
10. Preview the report to verify that Access saved the margins and orientation correctly.
11. Close the report.
12. On the Tools menu, point to Database Utilities, and then click Compact and Repair database.
13. Preview the "Sales by Category" report. Note that the settings still look correct.
14. Close the report, and then preview the report again.

Note that the report layout has changed. When you click Page Setup on the File menu, note that the printer settings have been reset to their default values in the Page Setup dialog box. The margins are set at 1", and orientation is set to Portrait.

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Scenario 2

After you modify the design of a table or query (not the names of any tables or fields) being used for the record source of a report, the printer settings for the report are reset to their default values after the second time that you preview the report.

To reproduce the second scenario, follow these steps:
1. Start Access 2000 and open the sample database Northwind.mdb.
2. On the Tools menu, click Options.
3. On the General tab, make sure that the Perform name AutoCorrect check box is selected. If not, click to select it, and then restart Access.
4. Create a new report based on the Customers table.
5.Add the CustomerID field to the report.
6. On the File menu, click Page Setup.
7. Change all margins to .25".
8. Click the Page tab.
9. Under Orientation, verify that the orientation is set to Landscape.
10. Close and save the report as testCustomers.
11. Preview the report to ensure that it is formatted correctly.
12. Close the report.
13. Open the Customers table in Design view.
14. Add some extra words to the Description property of the CustomerID field.
15. Save and close the table.
16. Preview the testCustomers report. Note that the settings still look correct.
17. Close the report, and then preview the report again.

Note that the report layout has changed. When you click Page Setup on the File menu, note that the printer settings have been reset to their default values in the Page Setup dialog box. The margins are now set at 1", and orientation is set to Portrait.

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Scenario 3

With Name Auto Correct on:
1.Create a report based on a query.
2.Set the Margins to .25 from the default of 1.
3.Save the report.
4.Rename the query.
5.Compact the database.
6.Reopen the report in print preview. Check the margins, and note that they have returned to 1 from .25.

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REFERENCES

For more information about printer settings, click Microsoft Access Help on the Help menu, type page setup in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

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APPLIES TO
Microsoft Access 2000 Standard Edition

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Keywords: 
kbreport kbprb kbpending kbprinters kbsettings KB240826

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