Help and Support
 

powered byLive Search

Error Message in Internet Connection Sharing Adapter Properties in Device Manager

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:241255
Last Review:January 25, 2007
Revision:1.2
This article was previously published under Q241255

SYMPTOMS

After you install Internet Connection Sharing (ICS) on a host computer, you may see an exclamation point in a yellow circle next to the ICS adapter in Device Manager. When you view the properties of the adapter, you may see the following error message:
The NDIS.VXD device loader(s) for this device could not load the device driver, code 2.
Also, the ICS icon may not appear on the taskbar.

Back to the top

CAUSE

This behavior can occur if another program is providing a Dynamic Host Configuration Protocol (DHCP) service for the host computer.

Back to the top

RESOLUTION

To resolve this behavior:
1.Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
2.On the Install/Uninstall tab, remove any program providing a DHCP service by clicking the program, and then clicking Add/Remove.
3.On the Windows Setup tab, double-click Internet Tools, and then click to clear the Internet Connection Sharing check box.
4.Click OK, and then click Yes when you are prompted to restart the computer.
5.Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
6.On the Windows Setup tab, double-click Internet Tools, click to select the Internet Connection Sharing check box, click OK, click OK, and then continue with the on-screen instructions to configure Internet Connection Sharing using the ICS Wizard.

Back to the top


APPLIES TO
Microsoft Windows 98 Second Edition
Microsoft Windows Millennium Edition

Back to the top

Keywords: 
kbdocfix kbnetwork kbprb KB241255

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.