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Remote Storage Migration Job Performance Begins to Degrade Over Time

Article ID:244832
Last Review:February 28, 2007
Revision:2.2
This article was previously published under Q244832

SYMPTOMS

Over time, Remote Storage nightly migration jobs begin to degrade in performance by taking longer to complete. For example, your RSS service logs (located in the Remote Storage snap-in) show the nightly scans and data transfers taking longer to complete in successive weeks. Normal recalls also begin to take an excessive amount of time to complete.

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CAUSE

Remote Storage maintains a list of pre-migrated files in a File System Agent (FSA) database, which is located in the %SystemRoot%\System32\FsaDb folder. A pre-migrated file is one that has been copied to offline storage but not yet truncated (data still resides locally on the volume). Because the volume free space is still above the desired level, files are only truncated when actual volume free space falls below the desired minimum.

If one of these pre-migrated files is opened or modified before it has been truncated, the file's last access time stamp is adjusted. However, the entry in the FSA database is not removed. If the file is later migrated again by Remote Storage, a new entry is created in the FSA database. This can cause the database to become filled with a large number of records (one for each file) and adversly effect performance.

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RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack
To work around the problem, periodically perform one of the following (approximately once every 2 to 3 months):
1.Stop all Remote Storage services.
2.Delete the files located in %SystemRoot%\System32\RemoteStorage\FsaDb\*.* (you may just want to rename all the files or copy them to a temporary folder until the operation is completed.)
3.Restart all Remote Storage services.
4.Schedule a Validate Files job on all managed volumes.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 1.

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Datacenter Server

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Keywords: 
kbbug kbfix kbnetwork kbwin2000sp1fix KB244832

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