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Error Message When You Attempt to Install Program Using Windows Installer

Article ID:251274
Last Review:November 1, 2006
Revision:2.3
This article was previously published under Q251274

SYMPTOMS

When you try to install a product on a computer running Windows NT 4.0 and Windows Installer starts, you may receive one of the following error messages:
The Windows Installer service failed to start. Contact your support personnel.
Error 1631: The Windows Installer service failed to start. Contact your support personnel.
Internal Error 2755: Please contact product support for assistance.
After you receive the error message, the installation quits.

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CAUSE

This behavior can occur when you try to install a program that is installed using Windows Installer. The following registry key contains a value of data type REG_EXPAND_SZ, and the string is null:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
Userenv.dll returns an error message when it tries to process the value, and Windows Installer quits. The following example shows a null value:
Value Name: CLASSPATH
Data Type: REG_EXPAND_SZ
String:

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RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date       Time       Size      File name     Platform
   ------------------------------------------------------
   1/18/2000  3:47p      76,048    Userenv.dll   Intel
   1/18/2000  3:47p     123,664    Userenv.dll   Alpha
				

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WORKAROUND

To work around this behavior, remove null environment variables before you install the program.

NOTE: The potential impact of removing such variable is unknown at this time.

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STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0.

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APPLIES TO
Microsoft Windows NT 4.0 Service Pack 3
Microsoft Windows NT 4.0 Service Pack 4
Microsoft Windows NT 4.0 Service Pack 5
Microsoft Windows NT 4.0 Service Pack 6
Microsoft Windows NT 4.0 Service Pack 6a
Microsoft Windows NT Workstation 4.0 Developer Edition
Microsoft Windows NT Workstation 4.0

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Keywords: 
kberrmsg kbbug kbfix kbqfe kbenv kbhotfixserver KB251274

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