Help and Support

Clear Text Password May Not Be Recognized

Article ID:257292
Last Review:February 21, 2007
Revision:3.3
This article was previously published under Q257292

SYMPTOMS

When you are using Windows 2000 with clear text passwords, the operation may not succeed. For additional information about using clear text passwords, click the article number below to view the article in the Microsoft Knowledge Base:
244627 (http://support.microsoft.com/kb/244627/EN-US/) How to Send Unencrypted Passwords to Connect Windows 2000 System

Back to the top

CAUSE

The unicode password length is not being set correctly. It is not accounting for the null character at the end of the string. Also, the password is not being set on a WORD boundary.

Back to the top

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack



Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was first corrected in Windows 2000 Service Pack 1.

Back to the top


APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition

Back to the top

Keywords: 
kbqfe kbhotfixserver kbbug kbfix kbwin2000sp1fix KB257292

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.