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LDAP Sessions Do Not Time Out Properly

Article ID:258066
Last Review:March 1, 2007
Revision:3.2
This article was previously published under Q258066

SYMPTOMS

The time-out mechanism for Lightweight Directory Access Protocol (LDAP) may not work, causing old connections to remain connected. As a result, hundreds of stale LDAP connections may exist on a computer. Although this does not prevent LDAP connections to the server, the stale connections may continue to use system resources until you reboot the server.

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CAUSE

The scheduler thread that determines when to time out LDAP connections does not correctly handle the rollover of the 32-bit time value returned by the GetTickCount function. When a rollover occurs, the server stops timing out inactive connections.

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RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was first corrected in Windows 2000 Service Pack 1.

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition

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Keywords: 
kbbug kbfix kbqfe kbwin2000sp1fix KB258066

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