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Setup Reports Cross-Linked Files But ScanDisk Reports No Errors

Article ID:279331
Last Review:January 29, 2007
Revision:1.3
This article was previously published under Q279331
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SYMPTOMS

You may receive the following error message while you are installing Windows:
ScanDisk for Setup
Setup Check detected a Cross Link.
Running ScanDisk does not correct this issue.

- or -

When Windows Millennium Edition (Me) Setup checks your hard disk for errors, you may receive the following error message:
There is a cross linked file on drive C: run scandisk /all from the Windows Me CD to fix the problem, setup cannot continue.

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CAUSE

Windows Setup checks your hard disks for cross-linked files and duplicate file names before actually running ScanDisk. If either problem is detected, Setup cannot continue and running ScanDisk may not correct the problem.

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RESOLUTION

To resolve this problem, use the appropriate method.

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Upgrading Windows 95B OEM Service Release 2 (OSR2) or Later

Run ScanDisk for Windows and choose to fix any errors that are reported. Make sure to click either Delete or Make copies under Cross-linked files in the ScanDisk Advanced Options dialog box. Also, click to select the Duplicate names check box under Check files for. To view the ScanDisk Advanced Options dialog box, click Advanced in ScanDisk.

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Upgrading Windows 95 (Retail) or No Previous Windows 95/98

Run ScanDisk (either the MS-DOS-based or the Windows-based version) and choose to fix any errors that are reported. If you run the Windows-based version of ScanDisk (Scandskw.exe), make sure to click either Delete or Make copies under Cross-linked files in the ScanDisk Advanced Options dialog box. To view the ScanDisk Advanced Options dialog box, click Advanced in ScanDisk. If this does not resolve the problem, obtain a third-party disk utility and check for duplicate file names.

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Running Windows Me Setup

To resolve this issue, run ScanDisk after you configure it to check for duplicate file names and cross-linked files:
1.Click Start, point to Programs, point to Accessories, point to System Tools, and then click ScanDisk.
2.Click Advanced, click Delete, click to select the Duplicate names check box, and then click OK.
3.Click to select the Automatically fix errors check box, and then click Start.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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MORE INFORMATION

Windows Setup reports the same error message whether cross-linked files or duplicate file names are detected. Some versions of ScanDisk are unable to fix duplicate file names.

Windows Setup performs the check for cross-linked files and duplicate file names even if Setup does not run ScanDisk (for example, if you start Setup with the /is switch to bypass ScanDisk). Both the MS-DOS-based and Windows-based versions of ScanDisk check for cross-linked files by default, but neither ScanDisk for MS-DOS nor ScanDisk for Windows 95 (retail version) check for duplicate file names. The ability to check for duplicate file names was added to ScanDisk for Windows in Windows 95 OSR2.

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APPLIES TO
Microsoft Windows Millennium Edition
Microsoft Windows 98 Second Edition
Microsoft Windows 98 Standard Edition

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Keywords: 
kberrmsg kbprb KB279331

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