Help and Support
 

powered byLive Search

Extensible Storage Engine Database Becomes Corrupted During Consistency Check

Article ID:296981
Last Review:March 2, 2007
Revision:3.2
This article was previously published under Q296981

SYMPTOMS

When an Extensible Storage Engine (ESENT) database is checking itself for consistency, database corruption may occur.

Back to the top

CAUSE

This issue can occur if a recovery fails during the redo phase of a ESENT database consistency check. The termination routine is not called with the proper error flag, and the database is marked as consistent even though recovery did not complete. The database can be attachable/mountable and then can become corrupted when it is used or if it is located on a drive that has low disk space.

Back to the top

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack

Back to the top

STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows 2000. This problem was first corrected in Windows 2000 Service Pack 2.

Back to the top

MORE INFORMATION

ESENT databases are used with various components such as Dynamic Host Control Protocol (DHCP) and Windows Internet Name Service (WINS). Subsequent attempts to run recovery on the database do not succeed because the database is marked as being consistent. Because the corruption is logical, a database that is incorrectly marked as consistent can be successfully backed up and the backup does not detect any errors.

Back to the top


APPLIES TO
Microsoft Windows 2000 Service Pack 1
Microsoft Windows 2000 Advanced Server

Back to the top

Keywords: 
kbbug kbfix kbprogramming KB296981

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.