Help and Support
 

powered byLive Search

You receive a "The Windows Installer service version on your system is too low" error message when you install the Office 2000 SP2 Update

Article ID:300359
Last Review:March 29, 2007
Revision:1.7
This article was previously published under Q300359
On This Page

SYMPTOMS

When you install the SP-2 update, you may receive the following error message:
The Windows Installer service version on your system is too low. It must be 1.10.0.0 or higher to apply this update.

Back to the top

CAUSE

This error message appears if the version of the Windows Installer on your computer is not at the version that is installed by the SR-1 update, or later. There is a current problem with the SR-1 update in which the Office files are updated to SR-1, but the Windows Installer is not updated. Therefore, when you run the SP-2 Update, you receive the error message.

Back to the top

RESOLUTION

To resolve this problem, use one of the following methods.

Back to the top

Method 1: Run the SR-1 Update Again

Even though you have already installed the SR-1 update, if you run it again, the Windows Installer will be updated to version 1.10.1029.1.

If you do not have the SR-1 update on your computer, click the following link to download the SR-1 update:
http://office.microsoft.com/downloads/2000/O2kSR1DDL.aspx (http://office.microsoft.com/downloads/2000/O2kSR1DDL.aspx)
After you download the update, double-click the file to update the Windows Installer.

NOTE: The SR-1 Update dialog boxes may indicate that the update was already applied. Ignore this text and continue with the update.

After you update the Windows Installer, run the SP-2 Update again.

Back to the top

Method 2: Download the Latest Version of the Windows Installer

Instead of running the SR-1 update again, you can download and install the latest version of the Windows Installer. To do this, follow these steps:
1.Click the appropriate link below for your version of Microsoft Windows:Microsoft Windows 95 or Microsoft Windows 98
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=F1B7A5B0-611B-45A7-A06D-CADFF33E64DA (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=F1B7A5B0-611B-45A7-A06D-CADFF33E64DA)
Microsoft Windows NT 4.0
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=F8CA7781-41DC-4A53-A574-82EB9CD85BBB (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=F8CA7781-41DC-4A53-A574-82EB9CD85BBB)
2.Click the link for InstMsi.exe under Download Now.
3.In the File Download box, select Save this program to disk, and then click OK.
4. In the Save As dialog box, specify a download location for InstMsi.exe, and then click Save.
5.Double-click the downloaded InstMsi.exe file to install the Windows Installer update.
6.Click Yes if prompted to restart your computer.
7.After your computer restarts, run the SP-2 Update.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Back to the top

MORE INFORMATION

NOTE: This problem with the SP-2 update only occurs if you use the update from the "Product Updates" page, not the Microsoft Download Center. However, the Windows Installer is still at the non SR-1 level if you apply the SP-2 update from the Download Center. Make sure to update the Windows Installer, if necessary, using Method 2 earlier in this article.

Follow these steps to verify the version of the Windows Installer that is on your computer:
1.Locate Msi.dll on your computer. By default, this file is in the \Windows\System folder on Windows 95 and Windows 98 computers, or the \Winnt\System32 folder on Windows NT 4.0 computers.
2.Right-click Msi.dll and then click Properties.
3.Click the Version tab. Any version that is earlier than 1.10.1029.1 causes the problem described in the "Symptoms" section.

Back to the top


APPLIES TO
Microsoft Office 2000 Premium Edition
Microsoft Office 2000 Professional Edition
Microsoft Office 2000 Standard Edition
Microsoft Office 2000 Small Business Edition
Microsoft Office 2000 Developer Edition
Microsoft Access 2000 Standard Edition
Microsoft Excel 2000 Standard Edition
Microsoft FrontPage 2000 Standard Edition
Microsoft Outlook 2000 Standard Edition
Microsoft PowerPoint 2000 Standard Edition
Microsoft Word 2000 Standard Edition

Back to the top

Keywords: 
kbtshoot kbupdate kbsetup kbprb kberrmsg kbpending KB300359

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.