Help and Support
 

powered byLive Search

Adding SCSI Controllers to Onboard SCSI

Article ID:103625
Last Review:November 1, 2006
Revision:2.1
This article was previously published under Q103625

SYMPTOMS

When adding SCSI controllers to a computer that already contains an onboard SCSI controller, you may receive the following error message:
Windows NT could not start because of a computer disk hardware configuration problem.
Could not read from the selected boot disk. Check boot path and boot hardware.

Please check the Windows NT documentation about hardware disk configuration and your hardware reference manuals for additional information.

Boot failed.

Back to the top

CAUSE

This error may be caused when additional SCSI adapters are installed on computers that contain an onboard SCSI controller. This can change the device ID of the onboard controller, causing Windows NT not to boot.

Back to the top

RESOLUTION

Editing the BOOT.INI file to change the SCSI() and /SCSIORDINAL: parameters corrects this problem.

Back to the top

MORE INFORMATION

To edit the BOOT.INI file to correct the above problem, do the following:

1.Remove the attributes from the BOOT.INI file with the ATTRIB command:
      ATTRIB -R -S -H BOOT.INI
							
2.Use Notepad to edit the BOOT.INI file.
3.Change the following lines in the BOOT.INI
      [boot loader]
      default=scsi(0)...
							
to
      default=scsi(z)...
							
and
      [operating system]
      scsi(0)...
							
to
      scsi(z)...
							
and
      SCSIORDINAL:0
							
to
      SCSIORDINAL:z
							
where z = the new ID of the onboard SCSI controller.
4.Save the BOOT.INI file.
5.Restore the attributes to the BOOT.INI file with the following command:
      ATTRIB +R +S +H BOOT.INI
							

Back to the top


APPLIES TO
Microsoft Windows NT Advanced Server 3.1
Microsoft Windows NT Workstation 3.1

Back to the top

Keywords: 
kbhardware KB103625

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.