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Replacing RAS in Network Setup After PTP Has Been Installed

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:117501
Last Review:August 9, 2004
Revision:2.2
This article was previously published under Q117501

SYMPTOMS

After you have previously set up Remote Access Services (RAS) and updated RAS with the Point-to-Point Server files (WFWPTP.EXE), you get caught in a loop when you are trying to restore RAS in Network Setup. For example, after removing RAS and restarting Windows for Workgroups, you try to restore RAS in the Add Network Adapter dialog box of Network Setup. At this point, you are prompted for files. When you respond "Yes To All" to replace the files, you receive ten instances of the following dialog box:
   Windows Setup

   The version of the file <filename> that you are installing conflicts
   with the version that is currently on your system. Do you want to
   replace the file on your system with the one you are installing?

   Yes     Yes to All     No
				
The filenames that appear in the dialog boxes are as follows:
RASAPI16.DLL
RASCAUTH.DLL
RASEXE.EXE
RASMAN.DLL
RASMON.EXE
RASMXS.DLL
RASPHONE.EXE
RASSAUTH.DLL
RASSER.DLL
RASSRV.DLL
Responding "No" appears to allow you to complete the setup properly; however, when you choose OK, you are prompted with the same ten dialog boxes. This loop continues until you replace the files.

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CAUSE

The files for the Point-to-Point Server are newer than those that ship with Windows for Workgroups 3.11, and Network Setup does not recognize them.

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RESOLUTION

The following file is available for download from the Microsoft Download Center:
DownloadDownload Wfwptp.exe now (http://download.microsoft.com/download/wfw311/ptpfile/1/wfw/en-us/wfwptp.exe)
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/EN-US/) How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

To work around this problem, respond "Yes To All" and "Yes" to replace the newer driver with the older file from the Windows for Workgroups disks. Restart Windows for Workgroups and then exit and reinstall the Point-to-Point Server files. Go to the directory or disk in which WFWPTP.EXE is located and run COPYPTP.BAT <C:\WINDOWS> (where C:\WINDOWS is your Windows for Workgroups directory). This replaces the Windows for Workgroups files with the updated files.

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APPLIES TO
Microsoft Windows for Workgroups 3.11

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Keywords: 
kbdownload kbgraphxlinkcritical KB117501

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