Help and Support
 

powered byLive Search

Error Messages in Mmsystem.dll or Rundll32

Article ID:138835
Last Review:May 10, 2007
Revision:1.6
This article was previously published under Q138835
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:
315854 (http://support.microsoft.com/kb/315854/EN-US/) Windows 98 and Windows Me Error Message Resource Center

SYMPTOMS

You may receive random general protection (GP) fault error messages in Mmsystem.dll. You may also receive one of the following error messages:
Rundll32 - This program has performed an illegal operation and will be shut down.

Rundll - This program has performed an illegal operation and will be shut down.
Clicking the Details button reveals a message similar to one of the following:
RUNDLL32 caused a General Protection Fault in module MMSYSTEM.DLL

RUNDLL caused a General Protection Fault in module MMSYSTEM.DLL at 000a:00000032
This error message is more likely to occur after you use the Add New Hardware tool in Control Panel.

Back to the top

CAUSE

This problem can occur if the "drivers=mmsystem.dll" line is missing from the [boot] section of the System.ini file.

Back to the top

RESOLUTION

To correct this problem, follow these steps:
1.Use any text editor (such as Notepad) to edit the System.ini file.
2.Add the following line to the [boot] section of the file:

      drivers=mmsystem.dll
    
					
3.Save and then close the System.ini file.
4.Restart your computer.

Back to the top

MORE INFORMATION

This problem can occur when the System.ini file has been replaced with the System.cb file.

Back to the top


APPLIES TO
Microsoft Windows 98 Standard Edition
Microsoft Windows 95
Microsoft Windows Millennium Edition

Back to the top

Keywords: 
kberrmsg kbgpf kbprb KB138835

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.