Help and Support
 

powered byLive Search

FP: Java Applet Doesn't Function if Class File Is Moved

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:161965
Last Review:October 7, 2003
Revision:2.0
This article was previously published under Q161965

SYMPTOMS

When you view a page that contains a Java applet in a web browser you receive the following error message:
Load: Class <applet name> not found.
where <applet name> is the name of the Java applet that cannot be found.

Back to the top

CAUSE

The location of the Java applet was changed in the FrontPage Explorer after you inserted it in the FrontPage Editor.

When you save the page in FrontPage Editor, the location of the Java applet is saved relative to the location of the page. When you move the Java applet to a different directory, this reference is no longer valid. When you browse the page, the Java applet does not load.

Back to the top

RESOLUTION

If you need to move a Java applet after it has been inserted on a page, you must also change the reference to the applet. To change the reference, use these steps:

1.Open the page in FrontPage Editor.
2.Right-click the Java applet, and then click Properties.
3.In the Applet Base URL box, type the correct path to the Java applet. Note that the path should be relative to the saved location of the page on which you inserted the Java applet.

Back to the top

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. This problem was corrected in Microsoft FrontPage 98 for Windows.

Back to the top


APPLIES TO
Microsoft FrontPage 97 Standard Edition
Microsoft FrontPage 1.0 for Macintosh

Back to the top

Keywords: 
kb3rdparty kbprb KB161965

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.