Help and Support
 

powered byLive Search

ACC95: Replication/Synchronization Fails, Error in Msjtrclr

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:173044
Last Review:November 17, 2000
Revision:1.0
This article was previously published under Q173044
Moderate: Requires basic macro, coding, and interoperability skills.

On This Page

SYMPTOMS

When you try to create a replica or synchronize an existing replica you receive the error:
Microsoft Access cannot complete this operation because it can't find or initialize the dynamic-link library Msjtrclr.
   Solution:

   Run Microsoft Access Setup again to reinstall Microsoft Briefcase
   Replication. During Setup, click Add/Remove, select Microsoft Briefcase
   Replication.

   If you want to preserve your security or custom settings, back up
   the Microsoft Access Workgroup Information file.

   For more information on backing up files, search the Microsoft Windows
   online index for 'backing up files.'
				

However, the solution suggested by the message does not resolve the problem.

Back to the top

CAUSE

You have installed a Microsoft Software Product that distributes a new version of the OLE automation files. Microsoft Access 7.0 relies on functionality that was changed in the newer version of these OLE automation files. For example, Microsoft Internet Explorer 4.0 will cause the behavior described in the SYMPTOMS section of this article.

Back to the top

RESOLUTION

To work around this problem, you can do one of the following:
Write Visual Basic code that creates the replica.

For example, you can use the MakeReplica method to create a new replica. However, the MakeReplica method can only be used if your application has Microsoft Access with Briefcase Replication installed.
Use Briefcase Replication.
Upgrade to Microsoft Access 97.

Back to the top

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access 7.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Back to the top

MORE INFORMATION

When you create a replica or synchronize using the menu commands in Microsoft Access, an OLE call is made to initialize the Microsoft Access Reconciler. (Msjtrclr) Due to changes in the new versions of the OLE files, this call causes the error described in the SYMPTOMS section occurs.

Back to the top

Steps to Reproduce Problem


1.Open the sample database Northwind.mdb.
2.On the Tools menu, point to Replication, and then click Create Replica.
3.Click Yes when asked if you want to close the database.

Note that you receive the error message described in the "Symptoms" section.

Back to the top

REFERENCES

For more information about the MakeReplica method, search the Help Index for "Makereplica method," or ask the Microsoft Access 97 Office Assistant.

Back to the top


APPLIES TO
Microsoft Access 95 Standard Edition

Back to the top

Keywords: 
kbbug kberrmsg KB173044

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.