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WD97: Error: "Cannot Access the File" After File Closed (ODMA)

Article ID:179435
Last Review:January 22, 2007
Revision:1.2
This article was previously published under Q179435

SYMPTOMS

When you are running Word 97 in a Document Management System (DMS) that uses the ODMA API, you may receive the following error message after copying a large amount of text and closing the document:

The process cannot access the file because it is being used by another process.
-or-
<document name> is in use by another application.
These error messages will occur when the DMS attempts to move or catalog the original Word document.

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CAUSE

This problem occurs because when you use the Cut or Copy commands to copy information, Word makes a copy of the information, saves it in memory, and makes a note of where the copied data is stored (Word caches the data). Word incorrectly keeps the pointer to this cached information after allowing the file to be closed. The error message is displayed when DMS attempts to move or catalog the original Word document.

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RESOLUTION

To correct this problem, obtain Microsoft Word 97 Service Release 2 (SR-2). information.

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STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. This problem was corrected in Microsoft Office 97 Service Release 2 (SR-2).

For additional information about SR-2, please see the following article in the Microsoft Knowledge Base:
151261 (http://support.microsoft.com/kb/151261/EN-US/) OFF97: How to Obtain and Install MS Office 97 SR-2

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REFERENCES

For additional information, please see the following articles in the Microsoft Knowledge Base:
174304 (http://support.microsoft.com/kb/174304/EN-US/) WD97: Save As Command Does Not Close the Previous Document

159963 (http://support.microsoft.com/kb/159963/EN-US/) WD97: Word 97 Supports ODMA

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APPLIES TO
Microsoft Word 97 Standard Edition

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Keywords: 
kbhotfixserver kbqfe kb3rdparty kbbug kbfaq kbfix kbinterop KB179435

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