Help and Support
 

powered byLive Search

Err Msg: Cannot Import <File>. Error Opening the File.

Article ID:187316
Last Review:November 15, 2006
Revision:1.1
This article was previously published under Q187316
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

When you double-click a registry entry (.reg) file, you may receive the following error message:
Cannot import <path to file>. Error opening the file. There may be a disk or file system error.

Back to the top

CAUSE

This error message can occur if the .reg file is located in a folder whose name contains spaces.

Back to the top

RESOLUTION

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

To resolve this issue, use either of the following methods:
Move the .reg file to a folder whose name does not contain spaces.
Use Registry Editor to modify the way Regedit.exe examines the path. To do so, use registry editor to modify the data value for the "(Default)" value in the following registry key:
HKEY_CLASSES_ROOT\regfile\shell\open\command
Change the data value to:
regedit.exe "%1"
NOTE: Make sure to include the quotation marks. After you make this change, quit Registry Editor and restart the computer.

Back to the top


APPLIES TO
Microsoft Windows 95
Microsoft Windows NT Workstation 4.0 Developer Edition
Microsoft Windows NT Server 4.0 Standard Edition
Microsoft Windows NT Server 4.0 Enterprise Edition

Back to the top

Keywords: 
kberrmsg kbprb KB187316

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.