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OFF97: SR-2 Patch Fails Even Though SR-1 Was Installed

Article ID:192816
Last Review:January 9, 2007
Revision:2.1
This article was previously published under Q192816
NOTE: Although the information and steps included in this article still apply to the updated SR-2 Patch, they are primarily intended for use with the original SR-2 Patch. For more information, please visit the following Microsoft Web site:
http://office.microsoft.com/en-us/assistance/HA010449981033.aspx (http://office.microsoft.com/en-us/assistance/HA010449981033.aspx)
Or, click the article numbers below to view the following articles in the Microsoft Knowledge Base:
192874 (http://support.microsoft.com/kb/192874/EN-US/) OFF97: An Overview of Microsoft Office 97 SR-2

194377 (http://support.microsoft.com/kb/194377/EN-US/) OFF97: Overview of the Updated Microsoft Office 97 SR-2 Patch
The updated SR-2 Patch and Microsoft Office 97 Version Checker are designed to help prevent the problem described in this article from occurring.
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SYMPTOMS

When you install the Microsoft Office 97 SR-2 Patch, you may receive the following error message:
Microsoft Office 97 SR-2
Microsoft Office SR-2 can not locate an installation of Office 97 SR-1 on this machine. If you are running Office 97 SR-2 from CD-ROM, first install Office 97 SR-1 from the CD-ROM. If you downloaded Office 97 SR-2 from the Web, first install Office 97 SR-1 from
http://www.microsoft.com/office/office97/ServiceRelease/sr1/AboutSR1.asp.
NOTE: The URL shown in this error message is incorrect. To obtain SR-1, go to the following address:
http://office.microsoft.com/en-us/assistance/HA010449921033.aspx (http://office.microsoft.com/en-us/assistance/HA010449921033.aspx)
You may receive this error message even though you already installed Microsoft Office 97 SR-1 on your computer.

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CAUSE

This problem may occur if any of the following conditions are true:
Your downloaded copy of the SR-2 Patch is damaged or corrupted.

-or-

The version number of one or more of the following files on your computer's hard disk drive is earlier than the version number of the file included in Microsoft Office 97 SR-1:
Mso97.dll
Excel.exe
Winword.exe
Outllib.dll
Msaccess.exe
Powerpnt.exe
-or-

The following key in your registry
HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\mso97.dll\Path
refers to an incorrect location for your Mso97.dll file.

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RESOLUTION

Make Sure Your SR-2 Patch is not Damaged or Corrupted

Before you proceed with the steps shown below, please make sure that your copy of the SR-2 Patch is not damaged or corrupted. The correct size of the downloaded original SR-2 Patch is 23.0 megabytes (24,165,848 bytes), as shown in Windows Explorer. If the size of your SR-2 Patch does not match this size, you can re-download the updated SR-2 Patch from the following address:
http://office.microsoft.com/en-us/assistance/HA010449981033.aspx (http://office.microsoft.com/en-us/assistance/HA010449981033.aspx)
If you are having trouble downloading the SR-2 Patch, you may want to try to download at night or during off-peak hours.

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Re-Download and Reinstall the SR-1 Patch

If you downloaded and installed the SR-1 Patch before August 1998, the SR-1 Patch may have been unable to properly update all of the files on your computer. Consequently, you may receive the error message mentioned in the "Symptoms" section when you run the SR-2 Patch.

To correct this problem, you must re-download the SR-1 Patch from the following address:
http://office.microsoft.com/en-us/assistance/HA010449921033.aspx (http://office.microsoft.com/en-us/assistance/HA010449921033.aspx)
After you have downloaded the SR-1 Patch, run it. Then, run the SR-2 Patch. If you still receive the error message mentioned in the "Symptoms" section, continue on to the next section.

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Detailed Steps to Correct the Problem and Install the SR-2 Patch

If the above procedures have not corrected the problem, follow these steps:
1.Using Notepad or any other text editor, open the log file created by the SR-2 Patch. The log file is called 97sr2_<#>.log, where <#> is a number (0, 1, 2, and so on). The log file is stored in either of the following folders:
C:\Program Files\Microsoft Office\Office
C:\Program Files\Microsoft Office\Office\Setup
NOTE: The folder where Microsoft Office 97 is installed may be different than C:\Program Files. Open the log file from the correct folder on your computer.
2.Search the log file for any of the lines of text shown in the table below. If a particular line of text appears in the log file, follow the procedures indicated under "Follow Procedures":
      Line of                                                Follow
      Text in Log File             Cause                     Procedures
      -----------------------------------------------------------------

      Excel is Office 97           Excel.exe version or      A, C, D
      base.                        file size is too low

      Word97 is Office 97          Winword.exe version or    A, C, D
      base.                        file size is too low

      Outlook is Office 97         Outllib.dll version or    A, C, D
      base.                        file size is too low

      Access is Office 97          Msaccess.exe version or   A, C, D
      base.                        file size is too low

      PowerPoint is Office 97      Powerpnt.exe version or   A, C, D
      base.                        file size is too low

      <Path>\MSO97.DLL is on the   Mso97.dll version or      A, C, D
      client machine but is less   file size is too low
      than sr1 level

      The file <path>\MSO97.DLL    Invalid Mso97.dll key     B, D
      does not exist               in registry
						
NOTE: It should not be necessary to follow a particular procedure unless indicated in the table above. For example, if the log file indicates that the version or file size of Excel.exe is too low, you should not need to edit the registry (Procedure B).
3.Close the log file when you are finished reading it.
NOTE: It is important to follow the steps for each procedure indicated in the table above. If you omit any steps, the SR-2 Patch may continue to fail when you run it.

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Procedure A: Delete Old/Duplicate Versions of Program Files

If the version number, file date, and/or file size of a program's executable are too low, or if there are duplicate program executables on your computer's hard disk drive, you may need to delete the executable(s). To do this, follow these steps:
1.On the Start menu, point to Find, and then click Files or Folders.
2.In the Named box, type the name of the file for which you want to search. It may be any of the following files:
      Minimum          Minimum
      File Name      SR-1 Version*    Size in Bytes*
      ----------------------------------------------

      Mso97.dll      8.0.4202         3,782,416
      Excel.exe      8.0a or higher   5,604,624
      Winword.exe    8.0              5,324,560
      Outllib.dll    8.02 or higher   4,375,312
      Msaccess.exe   8.0.4122         3,016,976
      Powerpnt.exe   8.0              3,499,792
						
* Note that the Version and Size may be higher than those shown here, due to maintenance releases, recalculation patches, and so on. The values shown here are the MINIMUM that are accepted by the SR-2 Patch.
3.In the Look In list box, select My Computer. Then, click Find Now.

The dialog box will find all copies of the specified file on your hard disk drive. By default, you should have one copy of the file in the following folder:
C:\Program Files\Microsoft Office\Office
Note that the file may appear in a different folder if you customized your installation of Microsoft Office 97. You may also have more than one copy of the file on your computer.
4.If more than one copy of the file is found, delete all of the files that are not in the C:\Program Files\Microsoft Office\Office folder. You can delete a file by right-clicking it, and then clicking Delete on the shortcut menu.
5.When only one file remains, right-click it. On the shortcut menu, click Properties.
If the Size (shown on the General tab) is smaller than that shown above, or if the File Version (shown on the Version tab) is lower than that shown above, delete the file. To do this, click Cancel. Then, right-click the file, and click Delete on the shortcut menu.

If the Size is greater than or equal to that shown above, and the File Version is greater than or equal to that shown above, the file need not be deleted. However, you may want to delete the file anyway. Click Cancel. If you want to delete the file, right-click the file, and click Delete on the shortcut menu.

6.If you want, you may repeat steps 1 through 4 for each file shown in the table above. However, it should only be necessary to do so if the file is specifically mentioned in the log file created by the SR-2 Patch.
7.After you have completed this procedure, go to Procedure C.

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Procedure B: Verify the Mso97.dll Key in Your Registry

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


If the Mso97.dll key in your registry refers to an incorrect location for Mso97.dll, the SR-2 Patch will fail. To correct this problem, follow these steps:
1.On the Start menu, point to Find, and click Files Or Folders.
2.In the Named edit box, type Mso97.dll. In the Look In list box, select My Computer. Then, click Find Now.
3.Write down the path shown for the Mso97.dll file. For example:
C:\Program Files\Microsoft Office\Office
NOTE: If no copy of Mso97.dll is found, you may need to reinstall Microsoft Office 97 and SR-1.
4.Close the Find dialog box.
5.On the Start menu, click Run. In the Open box, type regedit. Click OK.
6.In the registry tree, click the plus sign (+) to the left of the following items, in order:
HKEY_LOCAL_MACHINE
Software
Microsoft
Shared Tools
Then, click the mso97.dll folder.
7.In the right pane, click Path. On the Edit menu, click Modify. In the Value Data box, type the path you wrote down in step 3. Add \Mso97.dll to the end of the path, so that it resembles the following:
C:\Program Files\Microsoft Office\Office\Mso97.dll
8.In the left pane, click the Clients folder.
9.In the right pane, confirm that the path to the Office programs is correct.

You can use Windows Explorer to browse to the folder or use Find on the Start menu.
10.Click OK. Then click Exit on the Registry menu.
11.After you have completed this procedure, go to Procedure D.

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Procedure C: Reinstall Microsoft Office 97 and SR-1

At this point, it is likely that you have deleted at least one file from your computer's hard disk drive. The SR-2 Patch will not replace files that do not exist; therefore, you must now reinstall Microsoft Office 97 and SR-1 in order to replace the missing files.
If you originally installed Microsoft Office 97 and then ran the SR-1 Patch, you will need to reinstall Microsoft Office 97, and then rerun the SR-1 Patch.

To reinstall Microsoft Office 97:
1.On the Start menu, point to Settings, and click Control Panel. Double-click Add/Remove Programs. Select Microsoft Office 97, and click Add/Remove.
2.In the Microsoft Office 97 Setup dialog box, click Reinstall. You may be prompted for your Microsoft Office CD or floppy disks.
3.After Microsoft Office 97 has been reinstalled, re-run the SR-1 Patch. You can download the SR-1 Patch from the following address:
http://office.microsoft.com/en-us/assistance/HA010449921033.aspx (http://office.microsoft.com/en-us/assistance/HA010449921033.aspx)
If you originally installed the Microsoft Office 97 SR-1 Enterprise Update, simply reinstall it:
1.On the Start menu, point to Settings, and click Control Panel. Double-click Add/Remove Programs. Select Microsoft Office 97, and click Add/Remove.
2.In the Microsoft Office 97 Setup dialog box, click Reinstall. You may be prompted for your Microsoft Office CD or floppy disks.
After you have reinstalled Microsoft Office 97 and SR-1, go to Procedure D.

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Procedure D: Reinstall the SR-2 Patch

Now that you have corrected the problems indicated in the SR-2 Patch log file, you should be able to reinstall the SR-2 Patch.

If you still receive the error message mentioned in the "Symptoms" section, open the new SR-2 Patch log file and look for any of the lines of error text. If any errors appear in the log file, you may need to repeat these steps again.

If you continue to have problems installing the SR-2 Patch, you may need to completely remove Office 97 and SR-1. For information on how to completely remove Office 97 and SR-1, please click the article numbers below to view the following articles in the Microsoft Knowledge Base:
158658 (http://support.microsoft.com/kb/158658/EN-US/) OFF97: How to Completely Remove Microsoft Office 97

173431 (http://support.microsoft.com/kb/173431/EN-US/) OFF97: How to Completely Remove the SR-1 Patch and Patch Update

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If All Else Fails

If you have followed the above procedures and the SR-2 Patch continues to fail, you may need to call Microsoft Product Support and request assistance. When you do this, make sure that you have a copy of the SR-2 Patch log file available. The support professional will help you decide the best course of action to correct this problem.

To obtain the support phone number for your product, refer to your product literature or your support contract for the technical support number to call. Or, please visit Microsoft's "Phone Numbers & Support Options" Web page at the following Web address:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)

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STATUS

The behavior described in this article is by design of the Microsoft Office 97 SR-2 Patch; it will not install if non-SR-1 program files are found on your hard disk drive, or if the file Mso97.dll cannot be found using the Mso97.dll subkey in the registry.

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MORE INFORMATION

When you run the SR-2 Patch, it checks the file versions and sizes of certain critical files to make sure that you actually have Microsoft Office 97 SR-1 installed on your computer. If the version or file size of any of the files is lower than that used in SR-1, the SR-2 Patch will not install.

This problem may occur if the version of any of the following files is incorrect for any reason
Mso97.dll
Excel.exe
Winword.exe
Outllib.dll
Msaccess.exe
Powerpnt.exe
or if the registry key that refers to Mso97.dll refers to the incorrect location for the file.

These problems have been observed to occur in the following situations:
You installed Microsoft Office 97 and the SR-1 Patch. You then removed and reinstalled a component, or added a new component. Afterward, you did not reinstall the SR-1 Patch. As a result, there are some non-SR-1 program files on your computer.

You installed Microsoft Office 97. You then installed Microsoft Windows 98. When you installed the SR-1 Patch, the patch failed to properly update all of your files because the WinAlign feature included in Windows 98 had already modified your files.

You installed Microsoft Office 97. You then installed either Microsoft Project 98 or Microsoft Outlook 98. When you installed the SR-1 Patch, the patch failed to properly update all of your files because newer files had already been installed as part of Microsoft Project 98 or Microsoft Outlook 98.
The following text may also appear in the log file when the SR-2 Patch fails:
The SR2 patch will only operate when you have all the Office 97 apps upgraded to at least SR1
Sr1 is not found in the user's machine
Sr2 patch can not run without sr1 installed

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APPLIES TO
Microsoft Office 97 Service Pack 2

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Keywords: 
kbdownload kbprb kbsetup KB192816

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